• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Liutauras Vilda
  • Campbell Ritchie
  • Tim Cooke
  • Bear Bibeault
  • Devaka Cooray
Sheriffs:
  • Jeanne Boyarsky
  • Knute Snortum
  • Junilu Lacar
Saloon Keepers:
  • Tim Moores
  • Ganesh Patekar
  • Stephan van Hulst
  • Pete Letkeman
  • Carey Brown
Bartenders:
  • Tim Holloway
  • Ron McLeod
  • Vijitha Kumara

http://localhost:8080 shows page not diaplyed in browser.  RSS feed

 
Ranch Hand
Posts: 47
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am running Tomcat v.3.3 on windows xp box.
I start Tomcat from <tomcat_home>/bin/startup.bat and the following is displayed:
2003-11-07 14:57:47 - AutoDeploy: Expanding C:\jakarta-tomcat-3.3.1a\jakarta-tom
cat-3.3.1a\webapps\admin.war
2003-11-07 14:57:48 - AutoDeploy: Expanding C:\jakarta-tomcat-3.3.1a\jakarta-tom
cat-3.3.1a\webapps\examples.war
2003-11-07 14:57:48 - AutoDeploy: Expanding C:\jakarta-tomcat-3.3.1a\jakarta-tom
cat-3.3.1a\webapps\ROOT.war
2003-11-07 14:58:02 - ServerXmlReader: Config=$TOMCAT_HOME\conf\server.xml
2003-11-07 14:58:02 - PathSetter: home=C:\jakarta-tomcat-3.3.1a\jakarta-tomcat-3
.3.1a
2003-11-07 14:58:02 - ContextXmlReader: Context config=$TOMCAT_HOME\conf\apps-12
7.0.0.1.xml
2003-11-07 14:58:02 - ContextXmlReader: Context config=$TOMCAT_HOME\conf\apps-ad
min.xml
2003-11-07 14:58:02 - ContextXmlReader: Context config=$TOMCAT_HOME\conf\apps-ex
amples.xml
2003-11-07 14:58:02 - AutoWebApp: Loaded from config: DEFAULT:/admin
2003-11-07 14:58:02 - AutoWebApp: Loaded from config: DEFAULT:/examples
2003-11-07 14:58:02 - AutoWebApp: Auto-Adding DEFAULT:/
2003-11-07 14:58:02 - ContextManager: Tomcat configured and in stable state
2003-11-07 14:58:03 - WorkDirSetup: Creating work dir C:\jakarta-tomcat-3.3.1a\j
akarta-tomcat-3.3.1a\work\DEFAULT\admin
2003-11-07 14:58:09 - ContextManager: Adding DEFAULT:/admin
2003-11-07 14:58:09 - WorkDirSetup: Creating work dir C:\jakarta-tomcat-3.3.1a\j
akarta-tomcat-3.3.1a\work\DEFAULT\examples
2003-11-07 14:58:09 - ContextManager: Adding DEFAULT:/examples
2003-11-07 14:58:09 - WorkDirSetup: Creating work dir C:\jakarta-tomcat-3.3.1a\j
akarta-tomcat-3.3.1a\work\DEFAULT\ROOT
2003-11-07 14:58:09 - ContextManager: Adding DEFAULT:/ROOT
2003-11-07 14:58:09 - Ctx(/admin) : Validating web.xml
2003-11-07 14:58:09 - Ctx() : Validating web.xml
EmbededTomcat: Init time 22094
2003-11-07 14:58:12 - Http10Interceptor: Starting on 8080
2003-11-07 14:58:12 - Ajp12Interceptor: Starting on 8007
2003-11-07 14:58:12 - Ajp13Interceptor: Starting on 8009
EmbededTomcat: Startup time 2922

This shows that tomcat is successfully configured to default http port 8080
Althouh when I launch IE and type http://localhost:8080 it displays Page Not Found. Also tried http://127.0.0.1:8080 doesn't work.
I've made sure that the local address does not by pass a proxy server in my internet connections.
Please help me, I dont know what to do to get this to work?
 
Author and ninkuma
Marshal
Posts: 66806
168
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Moving to the Tomcat forum.
bear
 
Ranch Hand
Posts: 112
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Where did you put your html file that you are trying to hit?
It should be in <tomcat_home>\webapps\<app_name>.
You could then access the page at:
http://localhost:8080/myapp/myPage.html (my app being whatever you called your application).
-Graff
 
Annemarie McKeown
Ranch Hand
Posts: 47
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hey, I have tried this. I called my webapp /test and tomcat sees it ok when I start the server -
2003-11-08 15:09:12 - ServerXmlReader: Config=$TOMCAT_HOME\conf\server.xml
2003-11-08 15:09:12 - PathSetter: home=C:\jakarta-tomcat-3.3.1a\jakarta-tomcat-3
.3.1a
2003-11-08 15:09:12 - ContextXmlReader: Context config=$TOMCAT_HOME\conf\apps-12
7.0.0.1.xml
2003-11-08 15:09:12 - ContextXmlReader: Context config=$TOMCAT_HOME\conf\apps-ad
min.xml
2003-11-08 15:09:12 - ContextXmlReader: Context config=$TOMCAT_HOME\conf\apps-ex
amples.xml
2003-11-08 15:09:12 - AutoWebApp: Loaded from config: DEFAULT:/admin
2003-11-08 15:09:12 - AutoWebApp: Loaded from config: DEFAULT:/examples
2003-11-08 15:09:12 - AutoWebApp: Auto-Adding DEFAULT:/
2003-11-08 15:09:12 - AutoWebApp: Auto-Adding DEFAULT:/test
2003-11-08 15:09:12 - ContextManager: Tomcat configured and in stable state
2003-11-08 15:09:12 - ContextManager: Adding DEFAULT:/admin
2003-11-08 15:09:12 - ContextManager: Adding DEFAULT:/examples
2003-11-08 15:09:13 - ContextManager: Adding DEFAULT:/ROOT
2003-11-08 15:09:13 - WorkDirSetup: Creating work dir C:\jakarta-tomcat-3.3.1a\j
akarta-tomcat-3.3.1a\work\DEFAULT\test
2003-11-08 15:09:13 - ContextManager: Adding DEFAULT:/test
EmbededTomcat: Init time 2390
2003-11-08 15:09:14 - Http10Interceptor: Starting on 8080
2003-11-08 15:09:14 - Ajp12Interceptor: Starting on 8007
2003-11-08 15:09:14 - Ajp13Interceptor: Starting on 8009
EmbededTomcat: Startup time 1313

The browser doesn't seem to be connecting to http://localhost:8080 at all.
http://localhost:8080/index.html should display Tomcat's homepage, I don't even see this. All I get is Page cannot be displayed in the browser.
Do I need to change my Internet Connections or anything?
Do you know of anything else this could be.
I have tried with other versions of tomcat ie 4.124 and 4.129?
Please help!
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!