• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Jeanne Boyarsky
  • Tim Cooke
Sheriffs:
  • Bear Bibeault
  • Henry Wong
  • Devaka Cooray
Saloon Keepers:
  • salvin francis
  • Tim Moores
  • Tim Holloway
  • Stephan van Hulst
  • Frits Walraven
Bartenders:
  • Jj Roberts
  • Carey Brown
  • Scott Selikoff

Tomcat 4.1.29 starting issues

 
Ranch Hand
Posts: 30
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I have installed tomcat 4.1.29 on HP-UX. after starting tomcat I can see tthe following error in localhost_admin_log..txt log file.
>>
javax.servlet.ServletException: Wrapper cannot find servlet class org.apache.webapp.admin.ApplicationServlet or a class it depends on
....
....
----- Root Cause -----
java.lang.ClassNotFoundException: org.apache.webapp.admin.ApplicationServlet
at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1443)
at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1289)
..
..
>>
When I look for that class, the classname is actually truncated. Not only that class, many of the class names in
$CATALINA_HOME/server/webapps/admin/WEB-INF/classes/org/apache/webapp/admin
are truncated.
Any idea how to solve this? The server seems to run. But when I try to make some native calls they are failing. I wonder if it is related to these errors.
Any help is appreciated.
Thx
Shaju Joseph
 
Ranch Hand
Posts: 541
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
It sounds like that is the cause of your problems.
I don't know anything about your operating system but how did you isntall tomcat? Perhaps the extraction tool you used had a problem? Check the archive to see if they are OK inside it?
 
shaju joseph
Ranch Hand
Posts: 30
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Thanks Tim,
I am using HP-UX and I did an untar in order to install TOMCAT.
I will check the extract and see.
thx
 
Yup, yup, yup. Tiny ad:
Building a Better World in your Backyard by Paul Wheaton and Shawn Klassen-Koop
https://coderanch.com/wiki/718759/books/Building-World-Backyard-Paul-Wheaton
reply
    Bookmark Topic Watch Topic
  • New Topic