• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Jeanne Boyarsky
  • Tim Cooke
Sheriffs:
  • Bear Bibeault
  • Henry Wong
  • Devaka Cooray
Saloon Keepers:
  • salvin francis
  • Tim Moores
  • Tim Holloway
  • Stephan van Hulst
  • Frits Walraven
Bartenders:
  • Jj Roberts
  • Carey Brown
  • Scott Selikoff

deploy.wsdd on Axis

 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I use the command below
java org.apache.axis.client.AdminClient deploy.wsdd
and get: Exception:: org.xml.sax.SAXParseException: The markup in the document preceding the root element must be well-formed.
maybe something goes wrong in tomcat/conf/web.xml?
can anyone give advice? thanks!
 
Ranch Hand
Posts: 44
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
What is the port of the webserver you are using to run Axis?
I believe one has to indicate the port number with a -p flag when deploying, for example:
java org.apache.axis.client.AdminClient -p8080 deploy.wsdd
also make sure your deployment.wsdd has no xml-like declaration at the beginning just the deployment as root, service as first child and parameter as grandchildren

Hope that helps
reply
    Bookmark Topic Watch Topic
  • New Topic