• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

problem in installing tomcat

 
reddy kranthi
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
i have a problem in installing tomcat web server.
i followed the steps to instal
but finally it throws me some error showing
-Dsun.io.useCanonCaches=false
the version of j2sdk_nb is already installed
is that a problem for me.
i want another copy of tomcat
can anyone please help me
thanks in advance
 
Mark Spritzler
ranger
Sheriff
Posts: 17278
6
IntelliJ IDE Mac Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am going to move this thread to the Tomcat forum. This topic for this forum is Servlets, and you will get better response to your question in the Tomcat forum, since you are trying to install Tomcat.
Good Luck
Mark
 
shuzo monsoon
Ranch Hand
Posts: 54
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I've had the same problem myself. What it meant for me was that your JAVA_HOME environment variable is not correctly set, like i.e. c:\jdk1.4 either that or maybe you haven't defined your CATALINA_HOME path correctly for your tomcat? Hope this helps.
 
Franke Robinson
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I had the same problem also. It was because in my JAVA_HOME had c:\j2sdk1.4.2_02 with a ; after it. When I removed the ; it worked.
 
reddy kranthi
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hello frank,
i have set catalina_home= c:/tomcat
and i've also set
java_home c:/j2sdk_nb/j2sdk1.4.2
but it is still not working
i can start tomcat with ide .
but i am not able to install another copy of tomcat
is it a problem bcause of the old copy .
could u please help me.
 
William Brogden
Author and all-around good cowpoke
Rancher
Posts: 13073
6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
1. I really hope you mean JAVA_HOME etc in upper case.
2. If the directory c:/j2sdk_nb/j2sdk1.4.2 does NOT HAVE a bin subdirectory you are using the wrong home. Seems to me we had somebody else with a similar problem really recently.
3. Are you setting the environment variables for the whole system or just one command prompt window.
Bill
 
reddy kranthi
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Dear brogden,
thanks for showing intrest on my problem
what u mean was exactly right ie all u assumed are in capital letter case only
and i have set environmental variables for the whole system
i expect and appricate ur extended help
 
reddy kranthi
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
thanks for ur replies now it is working
i reinstalled and took the necessary mesures which u people suggested me
and now it is working
thanks to all
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic