• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Doubt on Tomcat Installation

 
mats davida
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have been trying to install tomcat server for long without much succes.The jdk is 1.8 and tomcat is 3.3.1 i guess.Although the environment variables and all others r set.The server does bind to local host..Please give me the possible remedy for this.Thank you.
 
chanoch wiggers
Author
Ranch Hand
Posts: 245
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
are you runnign windows? linux? is it possible that there is a server already set up on the port you are trying to bind to? this is quite possible. Alternatively 3.1 used to have a problem with jdk 1.1 because of an assumptions it made about class loaders which required a slight rewrite to the code base. A socket bind problem probably means you are on linux and you are trying to bind to a port that is either a) < 1024 and you havent got su rights or b) you have a server on that port already
 
Sean MacLean
author
Ranch Hand
Posts: 621
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
"matsdavida",
Thanks for participating here at the Ranch. However, the name you are using does not comply with our naming convention described at http://www.javaranch.com/name.jsp . Please log in with a new name, which meets these requirements.
You can change your name here.
Thanks.
Sean
 
Vedhas Pitkar
Ranch Hand
Posts: 445
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi!Why dont u download the latest versions of jdk & tomcat .They come as .exe files & u wont have to worry bout much when u run them.
 
Anjanesh Lekshminarayanan
Ranch Hand
Posts: 46
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have WinMe. I recently downloaded Tomcat 5. It was written that it would run as a WinNT/Win2K/WinXP service whatever may be the installation.
I ran tomcat.exe but nothing happened. The DOS window just opened & closed. I ran in DOS mode it gave no error. It wasn't running in the background(I checked ctrl+alt+del).
Anyone know how to get jsp scripts to work on Me ?
Thanks
Anjanesh
 
William Brogden
Author and all-around good cowpoke
Rancher
Posts: 13064
6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
We do have a Tomcat forum to take care of these specific questions.
If you browse the last few weeks of questions in that forum you may well find the answers to your problems.
Bill
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic