Win a copy of Functional Reactive Programming this week in the Other Languages forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

APACHE+SSL

 
Abhijeet Gholkar
Greenhorn
Posts: 25
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi guys
Iam trying to configure Apache 2.0.49+SSL (OpenSSL 0.9.7a) on SunOS 5.8
While configuring apache i found the following errors,
====================================================================
1.
configure:10642: checking for SSL_set_state
configure:10699: gcc -o conftest -g -O2 -pthreads -DSOLARIS2=8 -D_POSIX_PTHREAD_SEMANTICS -D_REENTRANT -L/teams5/home/abhijit/httpd-2.0.43/source/httpd-2.0.49/srclib/apr-util/xml/expat/lib -L/usr/local/ssl/lib -R/usr/local/ssl/lib conftest.c -lssl -lcrypto >&5
Undefinedfirst referenced
symbol in file
SSL_set_state /var/tmp//ccsDjMEg.o
ld: fatal: Symbol referencing errors. No output written to conftest
collect2: ld returned 1 exit status
configure:10705: $? = 1
============================================================
2.
configure:10744: checking for SSL_set_cert_store
configure:10801: gcc -o conftest -g -O2 -pthreads -DSOLARIS2=8 -D_POSIX_PTHREAD_SEMANTICS -D_REENTRANT -L/teams5/home/abhijit/httpd-2.0.43/source/httpd-2.0.49/srclib/apr-util/xml/expat/lib -L/usr/local/ssl/lib -R/usr/local/ssl/lib conftest.c -lssl -lcrypto >&5
Undefinedfirst referenced
symbol in file
SSL_set_cert_store /var/tmp//ccMdNa8Y.o
ld: fatal: Symbol referencing errors. No output written to conftest
collect2: ld returned 1 exit status
configure:10807: $? = 1
==================================================================
If i ignore this and move forward, i get following error on hitting apachectl startssl
======================================================================
[Fri Apr 16 02:07:16 2004] [crit] [Fri Apr 16 02:07:16 2004] file vhost.c, line 189, assertion "rv == APR_SUCCESS" failed
Abort - core dumped
======================================================================
Iam not sure if the error at apache statup is because of configuration error
Has anybody come across this problem ?
Regards
Raja
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic