Win a copy of Programmer's Guide to Java SE 8 Oracle Certified Associate (OCA) this week in the OCAJP forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

NoSuchMethodError Tomcat 5.0.19

 
Heta
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

This is urgent .Pls help

I was using Tomcat 4.x.x and my application was working fine.
Now i upgraded to Tomcat 5.0.19 and NOTHING is going fine.
Even the examples JSP(specifically JSP 2.0) are throwing errors.
The application which was running fine in 4.x.x is sick.
Did i missed out any new jar files to be in common/lib.

The below defined exception is that i got when on execution of a JSP2.0 example.

javax.servlet.ServletException:
javax.servlet.jsp.PageContext.getVariableResolver()Ljavax/servlet/jsp/el/VariableResolver;
org.apache.jasper.runtime.PageContextImpl.doHandlePageException(PageContextImpl.java:867)
org.apache.jasper.runtime.PageContextImpl.handlePageException(PageContextImpl.java:800)
org.apache.jsp.jsp2.el.basic_002dcomparisons_jsp._jspServic(basic_002dcomparisons_jsp.java:78)
org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:133)
javax.servlet.http.HttpServlet.service(HttpServlet.java:853)

root cause

java.lang.NoSuchMethodError:
javax.servlet.jsp.PageContext.getVariableResolver(Ljavax/servlet/jsp/el/Var
iableResolver
org.apache.jasper.runtime.PageContextImpl.proprietaryEvaluat(PageContextImpl.java:941)

org.apache.jsp.jsp2.el.basic_002dcomparisons_jsp._jspService(basic_002dcomparisons_jsp.java:43)
org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:133)
javax.servlet.http.HttpServlet.service(HttpServlet.java:853)

This one i got when i loaded the home page of my application.

javax.servlet.ServletException:javax.servlet.jsp.tagext.TagInfo.<init>(Ljava/lang/String;Ljava/lang/String;
Ljava/lang/String;Ljava/lang/String;Ljavax/servlet/jsp/tagext/TagLibraryInfo;Ljavax/servlet/jsp/tagext/TagExtraInfo;[Ljavax/servlet/jsp/tagext/TagAttributeInfo;Ljava/lang/String;Ljava/lang/String;Ljava/lang/String;[Ljavax/servlet/jsp/tagext/TagVariableInfo;Z)V


java.lang.NoSuchMethodError:javax.servlet.jsp.tagext.TagInfo.<init>(Ljava/lang/String;Ljava/lang/String;
Ljava/lang/String;Ljava/lang/String;Ljavax/servlet/jsp/tagext/TagLibraryInfo;Ljavax/servlet/jsp/tagext/TagExtraInfo;[Ljavax/servlet/jsp/tagext/TagAttributeInfo;Ljava/lang/String;Ljava/lang/String;Ljava/lang/String;[Ljavax/servlet/jsp/tagext/TagVariableInfo;Z)V
 
Mike Curwen
Ranch Hand
Posts: 3695
IntelliJ IDE Java Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The jar files I refer to below are ones like: servlet.jar, servlet-api.jar, etc. (tomcat internal jar files).


did you copy any jars from tomcat 4.x to 5.x ? do you have any jar files in your classpath or ext directory, etc.

If so, you should fix those up (move/remove them). It looks like you have older specification jar files where they shouldn't be.
 
Heta
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi

Thanks for your response.But i did'nt moved any files from Tomcat4.x to Tomcat 5.x.I had put JAR files like jta-spec.jar and j2ee-api.jar to tomcat lib.

Please help.
 
Mike Curwen
Ranch Hand
Posts: 3695
IntelliJ IDE Java Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
j2ee-api.jar is the culprit.

remove it and try again.
 
Heta
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Removed that.Still the same issue.

Thanks,
Sanooj
 
William Brogden
Author and all-around good cowpoke
Rancher
Posts: 13071
6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
It has got to be a JAR version issue like Mike suggested.
Somehow it is finding the wrong version of the javax.servlet.jsp related packages.
Read the Tomcat docs on class loading to get an idea of where to look.
Bill
 
Heta
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am pretty sure that it is the environment coz the same tomcat folder works in other PCs!!!

I have installed/uninstalled tomcat/jdk etc ...but everything in vain .
The envronment classpath is blank.
the jsp-api.jar contains the class/method it is showing as error...
I am out of options to try...it will be great if anyone help me with options?

Thx,
Heta
 
Pomeleau Martin
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Heta,

Did you finally find the problem? I am interested because I have exactly the same problem....
 
Consider Paul's rocket mass heater.
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic