• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Paul Clapham
  • Jeanne Boyarsky
  • Bear Bibeault
Sheriffs:
  • Rob Spoor
  • Henry Wong
  • Liutauras Vilda
Saloon Keepers:
  • Tim Moores
  • Carey Brown
  • Stephan van Hulst
  • Tim Holloway
  • Piet Souris
Bartenders:
  • Frits Walraven
  • Himai Minh
  • Jj Roberts

Tomcat 5.0.27 Set Up Problem

 
Ranch Hand
Posts: 1309
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I have downloaded the Tomcat 5.0.27 on the Windows XP (I have JDK installed OKay and tested). I am able to start the server; however I got HTTP Status 404 error after I typed http://localhost:8080 in the browser's address bar.

I primarily followed Marty's Hall's instruction for configuration at the web site http://www.moreservlets.com/Using-Tomcat-4.html

Nonetheless, I think his instruction is sort of out of date. Here is what I have done:

1. (done) downloaded and unzipped jakarta-tomcat-5.0.27

2. (problem) Marty Hall says "To enable it, uncomment the following line in the C:\jakarta-tomcat-5.0.27\conf\server.xml:"
<Context path="" docBase="ROOT" debug="0"/>

But, I do not find <Context path="" docBase="ROOT" debug="0"/>
in the server.xml. I installed the Tomcal 4.1.18 before, the
<Context ... > tag was there.

3. (done) I have followed Marty Hall's instruction and enabled the invoker servlet by uncommenting the following servlet-mapping element in C:\jarkata-tomcat-5.0.27/conf/web.xml

<servlet-mapping>
<servlet-name>invoker</servlet-name>
<url-pattern>/servlet/*</url-pattern>
</servlet-mapping>

4. (problem) Marty Hall says to "turn on servlet reloading" by insert the following line:
<DefaultContext reloadable="true"/>

just below the comment "<!-- Define properties for each web application. This is only needed if you want to set non-default properties, or have web application document roots in places other than the virtual host's appBase
directory. -->

I DO NOT FIND that comment in the C:\jakarta-tomcat-5.0.27\conf\server.xml anymore!

5. (done) set the JAVA_HOME variable

6. (not necessary) change DOS memory settings: If you use an older version of Windows, you may also have to change the DOS memory settings for the startup and shutdown scripts.

I am using the Windows XP; therefore, I do not think that I have to change DOS memeroy settings.

7. I edited C:\jakarta-tomcat-5.0.27\bin\catalina.bat and inserted the following after the first set of comments:

if not "%JAVA_HOME%" == "" goto gotJavaHome
set JAVA_HOME=C:\j2sdk1.4.0_02
:gotJavaHome

8. (done) The "Automatically detect settings" checkbox in IExplorer Connections is unchecked.

9. (problem) Internet Explorer --> Tools --> Internet Options -->
Connections --> Lan Settings --> check the box of
Bypass proxy server for local addresses

The Bypass proxy server for local addresses is grayed out, I cannot check the box.


Please advise what I have missed in the configurtion process. I appreciate your help.

And, I have one more question. When I used the Tomcat 4.1.18, I copied the servlet.jar file from C:\jakarta-tomcat-LE-4.1.18\common\lib to the C:\j2sdk1.4.2\lib directory. However, I do not find servlet.jar file in the Tomcat 5.0.27. I only find servlet-api.jar in the jakarta-tomcat-5.0.27\common\lib directory. Are servlet-api.jar (5.0.27 version) and servlet.jar (4.1.18 version) the same thing?


[ August 30, 2004: Message edited by: JiaPei Jen ]

[ August 30, 2004: Message edited by: JiaPei Jen ]
[ August 30, 2004: Message edited by: JiaPei Jen ]
 
Greenhorn
Posts: 24
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I thing you shouldn't change any settings in server.xml and web.xml.
Just unpack tomcat and set JAVA_HOME variable to directory where your
SDK is installed. Then set CATALINA_HOME variable to directory
where you unpacked tomcat. That is it!!! That configuration file seems to
be out of date! Of course you should change configuration in server.xml
if you know what you want but for simple startup this was enough to work
at my machine (winXP, tomcat 5.0.28)

peace....
 
asirob civokviz
Greenhorn
Posts: 24
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
just saw second question!!!

It seems that they DID changed name of .jar file. servlet_api.jar was
previously known as servlet.jar....
 
Can you smell this for me? I think this tiny ad smells like blueberry pie!
SKIP - a book about connecting industrious people with elderly land owners
https://coderanch.com/t/skip-book
reply
    Bookmark Topic Watch Topic
  • New Topic