Win a copy of The Java Performance Companion this week in the Performance forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Context problem on Tomcat 4.1.30

 
Eelco den Heijer
Ranch Hand
Posts: 61
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi, I'm having problems getting my lil'webapps to work on Tomcat 4.1.30.
This is what I did:
1. I created a service
2. I created a host under this service (test.objectivation.com), test.objectivation.com is an alias for 127.0.0.1 which I added to my hosts file
3. I created a HTTP connector under this service, listening to 9001

I enabled auto-deploy, set the baseDir to c:/temp/objectivation/.

Next I copied fresh war files (5) to this directory; restart Tomcat. Tomcat unpacks all 5 war files, no error messages.

Next, I go to http://test.objectivation.com:9001/guestbook/
and I get an error 500 saying

the log says the following:


the tragic thing is that all this worked without any problem in the same config on Tomcat 5 (yet TC5 gave me other headaches)

Any suggestions are more than welcome
 
Eelco den Heijer
Ranch Hand
Posts: 61
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
sorry, I forgot to paste the error 500 message:
The server encountered an internal error (No Context configured to process this request) that prevented it from fulfilling this request.

the context that is supposed to be missing is in both my admin page and in the server.xml.... And I get this error for all 5 webapps......
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic