[Logo]
Forums Register Login
Tomcat - java.lang.NoSuchMethodError with include
I'm currently moving a webbased application from Tomcat 4 to Tomcat 5.

Tomcat: jakarta-tomcat-5.0.28
Java: j2sdk1.4.2_06
System: Linux 2.6.10 FC3

While migrating I experienced following problem when I start the application:


I start Tomcat from Eclipse with Sysdeo's Tomcat Plugin for Eclipse.

I tried to track down the problem without any result. It seems do be some kind of conflict. The Method org.apache.jasper.runtime.JspRuntimeLibrary.include is located in /tomcat5/common/lib/jasper-runtime.jar so it should be available to Tomcat. This package is also located in j2ee.jar, but I have already tried to exclude this package without any result.

Any ideas???
This sometimes happens if you bring over some of the old jar files from the previous version of Tomcat that you were running.

Try with a clean install.
Wink, wink, nudge, nudge, say no more ... https://richsoil.com/cards



All times above are in ranch (not your local) time.
The current ranch time is
Nov 24, 2017 19:19:09.