• Post Reply Bookmark Topic Watch Topic
  • New Topic

Problem in starting Tomcat in debug mode  RSS feed

 
Jitesh Sinha
Ranch Hand
Posts: 146
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi all,

I am trying to start Tomcat 5.0.28 in debug mode by issuing command CATALINA_HOME/bin/catalina.bat jpda start from command line.
I have set JPDA_ADDRESS in environment variable as 8000.

As soon as I press enter on the command line it shows following lines :

Using CATALINA_BASE: value of TOMCAT_HOME
Using CATALINA_HOME: value of TOMCAT_HOME
Using CATALINA_TMPDIR: value of TOMCAT_HOME\temp
Using JAVA_HOME: D:\JDeveloper\jdk

After that I get a new window with the text :
Unauthorized option -Xdebug
cannot create virtual machine

This new window closes very quickly.So I cannot get tomcat started.

If I type in just CATALINA_HOME/bin/catalina.bat tomcat starts without any problem.
Any help will be greatly appreciated.
 
Jitesh Sinha
Ranch Hand
Posts: 146
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Also , I have already used up other options as well like :
1.)editing catalina.bat and adding the lines :
set JPDA_TRANSPORT=dt_socket
...
set JPDA_ADDRESS=8000
AND
2.)Editing startup.bat
call "%EXECUTABLE%" jpda start %CMD_LINE_ARGS%

After that I simply give startup from command line and get the same error as in my 1st post.
[ February 15, 2005: Message edited by: Jitesh Sinha ]
 
Jitesh Sinha
Ranch Hand
Posts: 146
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Never mind...The above mentioned problem vanished by installing a fresh jdk 1.4.2...Now I get another problem when I try to debug from eclipse :

Failed to connect to VM.connection refused.

Does anyone have any idea why that would come?
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!