Win a copy of Secure Financial Transactions with Ansible, Terraform, and OpenSCAP this week in the Cloud/Virtualization forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Paul Clapham
  • Jeanne Boyarsky
  • Bear Bibeault
Sheriffs:
  • Rob Spoor
  • Henry Wong
  • Liutauras Vilda
Saloon Keepers:
  • Tim Moores
  • Carey Brown
  • Stephan van Hulst
  • Tim Holloway
  • Piet Souris
Bartenders:
  • Frits Walraven
  • Himai Minh
  • Jj Roberts

Setup J2EE SDK 1.4.01 & Tomcat 5.5.7 environmental variables in Win XP SP2

 
Greenhorn
Posts: 9
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,
I need help getting Tomcat running. I have searched Javaranch's Apache/Tomcat forums, Sun's Java forums, and Google, but cannot find an anwser. I also tried the Tomcat and J2EE documentation but was still unable to resolve this.

I have a fresh install of Win XP SP2. Using the default setups, I have just installed:
-j2eesdk-1_4_01_2005Q1-windows.exe (All-In-One Bundle from http://java.sun.com/j2ee/1.4/download.html#sdk )
-jakarta-tomcat-5.5.7.exe(Binary from http://jakarta.apache.org/site/downloads/downloads_tomcat-5.cgi )

Everything I have read says to set the environmental variables to something like this:
JAVA_HOME: C:\j2sdk1.4.0_01\
PATH:C:\j2sdk1.4.0_01\bin;

But here lies the problem:
I do not have a directory called C:\j2sdk1.4.0_01. I have:
- C:\Sun\AppServer
- C:\Program Files\Apache Software Foundation\Tomcat 5.5

What I need help with is setting the following variables:
- J2EE_HOME
- JAVA_HOME
- CLASSPATH
- Path

Any help you can provide is sincerly appreciated.

John,
Athens, OH
 
Sheriff
Posts: 13411
Firefox Browser VI Editor Redhat
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Tomcat ships with the J2EE components that it needs.
You will only need an SDK. (standard edition).

For Tomcat 5.5, you will need at least version 1.5
which at the time of this posting is being called J2SE 5.0.

You can also get away with j2sdk1.4.xxx if you download and install the compat package as described in the Tomcat documentation.
 
John Croucher
Greenhorn
Posts: 9
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Ben,
You mentioned Tomcat ships with the J2EE components that it needs and that I only need an standard edition SDK.

Would you recommend I uninstall the J2EE SDK 1.4.01 and install J2SE 5.0?

Thanks,
John
[ April 02, 2005: Message edited by: John Croucher ]
 
Ranch Hand
Posts: 405
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Yes.

Tomcat ships with the J2EE components that it needs.



What that means is that only the SERVLET/JSP packages of the Java Enterprise Edition are bundled in the TOMCAT installation. But since TOMCAT is a servlet/jsp container, jou have all of the J2EE components you will need.
 
Please do not shoot the fish in this barrel. But you can shoot at this tiny ad:
SKIP - a book about connecting industrious people with elderly land owners
https://coderanch.com/t/skip-book
reply
    Bookmark Topic Watch Topic
  • New Topic