Win a copy of TDD for a Shopping Website LiveProject this week in the Testing forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Jeanne Boyarsky
  • Tim Cooke
Sheriffs:
  • Liutauras Vilda
  • paul wheaton
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Tim Holloway
  • Stephan van Hulst
  • Carey Brown
  • Frits Walraven
Bartenders:
  • Piet Souris
  • Himai Minh

symbolic link directory within webapp directory

 
Greenhorn
Posts: 9
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I have set up a web application in a directory outside of the webapps directory on a unix box and created a symbolic link to the directory within the webapps directory. ie. directory is '/home/fitcorp/fitcorpdev/'
with a symbolic link 'webapps/dev'.

I have added the new application to the server.xml document for tomcat and when I start tomcat 4.1 it recognises the application and creates no errors in the log files. However when I try to access a servlet in the application it writes to the log file that it has started the application using the default directory structure and cannot access the web.xml file. The application throws an error stating it cannot access the servlet.

I'm not sure why it is trying to start the application again. Is it something to do with having a symbolic link in the directory?

If anyone can offer any suggestions they would be greatly appreciated
 
Sheriff
Posts: 13411
Firefox Browser VI Editor Redhat
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Did you set the "allowLinking" attribute to true?

http://jakarta.apache.org/tomcat/tomcat-5.5-doc/config/context.html
 
Fred Rogan
Greenhorn
Posts: 9
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Thanks Ben.

allowLinking was not included in my context tag, default is false. When I added it and set it to true my problems were resolved.
 
Slime does not pay. Always keep your tiny ad dry.
free, earth-friendly heat - a kickstarter for putting coin in your pocket while saving the earth
https://coderanch.com/t/751654/free-earth-friendly-heat-kickstarter
reply
    Bookmark Topic Watch Topic
  • New Topic