• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Tomcat Starting problem with IllegalMonitorstateexception

 
Prashanth Chandra
Ranch Hand
Posts: 79
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
I am facing a problem when i ever i start tomcat server which says Illegal MonitorState Exception. Everytime i start the server this problem occurs again and again. To resolve this i have put in the class path as JAVA_COMPILER=none, but this problem still occurs. Could someone please help me out.

Thanks in advance
regards
Prashanth
 
William Brogden
Author and all-around good cowpoke
Rancher
Posts: 13071
6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
says Illegal MonitorState Exception

Surely it provides more information than that, such as the class that is throwing the exception.

Additional information that would help:
Operating system
Java version installed - version number, is it just the JRE or full SDK?
What does environment variable JAVA_HOME point to
Tomcat version
How Tomcat was installed
Why did you think JAVA_COMPILER=none would fix it

Bill
 
Prashanth Chandra
Ranch Hand
Posts: 79
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Bill

Operating system : RHEL 3.0

Java version installed - version number : j2sdk1.4.1_03

is it just the JRE or full SDK? : FULL SDK

What does environment variable
JAVA_HOME point to Tomcat version : jakarta-tomcat-5.0.27

How Tomcat was installed : The tar.gz file was extracted.

Why did you think JAVA_COMPILER=none
would fix it : I had read the same in some of forums saying the same that it would be enough if this would be put in the classpath as the Compiler would be searching for some threads which were stopped while running.
 
William Brogden
Author and all-around good cowpoke
Rancher
Posts: 13071
6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
JAVA_HOME point to Tomcat version : jakarta-tomcat-5.0.27

JAVA_HOME should point to your SDK installation, not tomcat.
As I recall, Tomcat 5 requires SDK 1.5 -or- the installstallation of a compatibility package
which appears on this download list.
Unless you have a realllly good reason to stick with SDK 1.4, you should (in my opinion) upgrade to 1.5.
Bill
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic