Win a copy of The Java Performance Companion this week in the Performance forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

cookies="false" doesn't work in all cases

 
Roman Tomachinsky
Greenhorn
Posts: 12
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi!

Please suggest me, how to force use URL encoding. It seems that Tomcat has a bug with context parameter "cookies". It works only if cookies are disabled on the client side.
So, I have strange behaviour - if cookies = false and browser accepts cookies, then Tomcat doesn't use cookies for session tracking, but doesn't encode URLs as well. When I disable cookies in the browser - all is OK, Tomcat starts URL encoding.
I think this is incorrect. If I use cookies="false" then Tomcat must not use cookies regardless client settings.
 
Bear Bibeault
Author and ninkuma
Marshal
Pie
Posts: 64980
86
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
"Roman T.",

There aren't many rules that you need to worry about here on the Ranch, but one that we take very seriously regards the use of proper names. Please take a look at the JavaRanch Naming Policy and adjust your display name to match it.

In particular, your display name must be a first and a last name separated by a space character, and must not be obviously fictitious.

Thanks!
bear
JavaRanch Sheriff
 
Roman Tomachinsky
Greenhorn
Posts: 12
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thank you. I've updated display name.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic