• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Tomcat connector with IIS 6.0

 
Jason Kwok
Ranch Hand
Posts: 126
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

I've been reviewing articles on making a tomcat connector but I'm still having a little difficulty getting things to work.

I'm using Tomcat 4 and Microsoft IIS 6.0. If anyone knows of any good (and simple) instructional walkthroughs, or able to give one yourself , I'd really appreciated any help you could provide!!

Thanks,
Jason
 
Jason Kwok
Ranch Hand
Posts: 126
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Ok I think I've got the connector working, but I had to upgrade Tomcat 4.0 to 5.5.

However, now that I've done that, my servlets won't work giving me this error:



I know it's because tomcat 5.5 supports the newer servlet standards. What do I have to do to fix a NoClassDefFoundError? P.s. I can't post a sample servlet if that helps, just let me know.

Thanks,
Jason
 
Ben Souther
Sheriff
Posts: 13411
Firefox Browser Redhat VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Did you try changing the name of your controller?
IllegalName: acs/controllers/StartUpController
 
Jason Kwok
Ranch Hand
Posts: 126
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Ok, that sounds really simple... but change it to what?

In my web.xml file, the servlet in this case is defined as StartUpController, and I have a servlet mapping as just /StartUp. I don't know what to change it to? the 'acs/controllers' part refers to the packages I've created.

Thanks for helping me out Ben!

J
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic