• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Junilu Lacar
Sheriffs:
  • Rob Spoor
  • Liutauras Vilda
  • Tim Cooke
Saloon Keepers:
  • Tim Moores
  • Piet Souris
  • Tim Holloway
  • Jj Roberts
  • Stephan van Hulst
Bartenders:
  • Himai Minh
  • Carey Brown
  • Frits Walraven

tomcat access log shows 0 bytes sent ("-") for big files

 
Hooplehead
Posts: 136
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi all,

Got a little problem I am a bit preplexed about. We are running Tomcat 5.5.17 on Widows Server 2003. Everything is up and running and working just fine.

BUT...the access logs show that large static media files (from low MB to maybe 20mb) being served up HTTP 200 OK with "-" (zero) bytes sent. This is jut not correct. Effected are all .flv and most all .mp3 files. Log format is 'combined'.



Can anybody help? Even 'try researching X' would help at this point...my hours spent on google have been useless.

tia,

Stu

[ September 10, 2006: Message edited by: Stu Thompson ]
[ September 10, 2006: Message edited by: Stu Thompson ]
 
Stu Thompson
Hooplehead
Posts: 136
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Update: This is only happening on one of three servers, which stupifies me even more.

Any help would be more than welcome!

Stu
 
Sheriff
Posts: 13411
Firefox Browser VI Editor Redhat
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Are the files actually making it to the browser?
 
Stu Thompson
Hooplehead
Posts: 136
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Yup, all works ok. I specifically cleared my cache and watched it download a 20mb file over a few minutes...and still see - for the bytes sent value.
[ September 11, 2006: Message edited by: Stu Thompson ]
reply
    Bookmark Topic Watch Topic
  • New Topic