• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Jeanne Boyarsky
  • Devaka Cooray
  • Paul Clapham
Sheriffs:
  • Tim Cooke
  • Knute Snortum
  • Bear Bibeault
Saloon Keepers:
  • Ron McLeod
  • Tim Moores
  • Stephan van Hulst
  • Piet Souris
  • Ganesh Patekar
Bartenders:
  • Frits Walraven
  • Carey Brown
  • Tim Holloway

How to prevent startup of Tomcat as service

 
Ranch Hand
Posts: 67
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello,

I got machine with Tomcat 5.0 already installed by previous user of the machine.
Everytime I startup the machine, tomcat starts as service.
I want to start up tomcat only when I need it and not on machine startup.
Are ther any settings which I need to alter for this to take effect?
Please suggest.
 
Sheriff
Posts: 13411
Firefox Browser VI Editor Redhat
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
All of your Windows services can be controlled from the "services" windows.
Control Panel -> Administration -> Services.
Right click on "Apache Tomcat" and you will have options to change startup from automatic to manual.
 
Shantanu Puranik
Ranch Hand
Posts: 67
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks Ben,

But I was surprised to see that StartUp Type for Apache Tomcat service is manual and not automatic.
 
Ben Souther
Sheriff
Posts: 13411
Firefox Browser VI Editor Redhat
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Maybe someone else changed this on your server.
It installs with a default value of "automatic".
 
Shantanu Puranik
Ranch Hand
Posts: 67
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello Ben,

Problem is solved. Thanks to my friend.
Removed shortcut for Start Tomcat from
<Drive>\Documents and Settings\All Users\Start Menu\Programs\Startup

now I felt, it was sheer common sense which I forgot, I do have.



[ April 10, 2007: Message edited by: shantanu puranik ]
 
It is sorta covered in the JavaRanch Style Guide.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!