• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Jeanne Boyarsky
  • Devaka Cooray
  • Paul Clapham
Sheriffs:
  • Tim Cooke
  • Knute Snortum
  • Bear Bibeault
Saloon Keepers:
  • Ron McLeod
  • Tim Moores
  • Stephan van Hulst
  • Piet Souris
  • Ganesh Patekar
Bartenders:
  • Frits Walraven
  • Carey Brown
  • Tim Holloway

Tomcat installation problem

 
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi, I'm trying to install tomcat 6 on x64-86 linux. I downloaded core tomcat package, then I unpacked it. Server starts with no error messages (using $CATALINA_HOME/bin/startup.sh). Everything seems to be ok, but , I can't to connect to the welcome page . I've checked if tomcat ports are in use (netstat -ln), but only my server after start is listening.
I'm using custom port, but I've also tested 8080 with no positive results. It can't be firewall problem, I've run run my old simple server program, and I can connect to it, without any problems. But tomcat still doesn't work .

In catalina.log:


localhost.log


What is going one? Please help me!!
[ November 28, 2007: Message edited by: Piotrus Kowalsky ]
 
Ranch Hand
Posts: 405
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
What port are you using to connect to tomcat locally?

 
Piotrus Kowalsky
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I've tried to start tomcat on default ports 8080 - I can't connect. I've also tested other ports (11000, etc). Each port is open and not used. After tomcat starts, netstat shows that serwer is listening, but I can't connect.

I've tested all these ports, other services (for example simple echo programs) can use them without any problems
 
Piotrus Kowalsky
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
More info, after shutdown I've got fallowing error:
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!