Win a copy of Murach's Python Programming this week in the Jython/Python forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

Tomcat6.0 startup!! IllegalArgumentException  RSS feed

 
palla sridhar
Ranch Hand
Posts: 111
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi!
I'm using Tomcat6.0.14 and SysdeoTomcat plugin in Eclipse 3.3.
Some time back, when i ran Tomcat from Eclipse, it worked fine..
I installed Tomcat as a service.

I also have Netbeans6.0 installed, which requires Tomcat to be installed as an archive.

So now,i've two Netbeans instances (6.0 only) in two different locations.
My CATALINA_HOME is the TOMCAT archive home.

I get the following error when i run Tomcat SERVICE from Eclipse.



Previosly i used D:\NetBeansPrj as a folder for NetBeans development.
Now i dont have that directory.
Tomcat service server is running fine, even with the IllegalArgumentException.

I checked starting a web-application and that's also running fine..

But can anybody help, why i'm getting this IllegalArgumentException and how can i remove this error on start-up??


[Jesper Young: Edited for readability]
[ January 02, 2008: Message edited by: Jesper Young ]
 
Jesper de Jong
Java Cowboy
Sheriff
Posts: 15859
80
Android IntelliJ IDE Java Scala Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You have a reference to D:\NetBeansPrj somewhere in your Tomcat configuration. Look through the Tomcat configuration files (especially server.xml) and make sure to remove references to that directory.
 
It is sorta covered in the JavaRanch Style Guide.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!