Win a copy of Microservices Testing (Live Project) this week in the Spring forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Tim Cooke
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Liutauras Vilda
  • Henry Wong
  • Devaka Cooray
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • Al Hobbs
  • Carey Brown
Bartenders:
  • Piet Souris
  • Mikalai Zaikin
  • Himai Minh

unable to get tomcat home page displayed in browser

 
Ranch Hand
Posts: 50
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,

I have installed jakarta-tomcat-5.0.28 on Solaris 10 server. The server is in LAN. When i try http://<serverip>:8080 from my machine, tomcat homepage is not displayed.

The error message is

" Network Access Message: The page cannot be displayed " and "Error Code: 502 Proxy Error. The ISA Server denied the specified "

But from my machine command prompt, when i telnet using

telnet <serverip> 8080

then GET / HTTP/1.0

default home page is displayed in command prompt.

Is this error related to some firewall enabled in server?

Thanks in advance,
Susmitha.
 
Sheriff
Posts: 13411
Firefox Browser VI Editor Redhat
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
If you can see the Tomcat homepage from a telnet prompt then Tomcat is running fine. It sounds like your browser is configured to use a proxy server that can't reach your Solaris box.
 
Susmitha Metlapalli
Ranch Hand
Posts: 50
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I am facing another problem with tomcat.

Using putty session, i started tomcat on my server. I am able to see that tomcat is up when putty window is open.

When putty session window is closed, Tomcat is shutting down automatically.

What could be the reason...?

Thanks,
susmitha.
 
reply
    Bookmark Topic Watch Topic
  • New Topic