Win a copy of Functional Reactive Programming this week in the Other Languages forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Web Service deployed on Tomcat stops responding after sometime

 
Mike Boota
Ranch Hand
Posts: 82
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

I haven't used Tomcat before and is the first time I am using it. I have Web Service that is deployed on Tomcat 5 installed on my local system. Web Service I am using Spring, Hibernate. The issue I am facing is
after deploying a service all works fine. As soon as I leave the service idle means I don't make any calls to the Web Service for couple of hours
my Web Service stops working. If I try to invoke a Web Service I get an error message and looking at the logs I don't see any call to the Web Service so I end up undeploying and redeploying the Web Service and it starts working and if I don't invoke the Service for couple of hours it stops working and I then I have to undeploy and redeploy the Service.

Any idea waht might be the problem where to look. Why the Service keeps working as long as I keep calling but stops working if I call after couple of hours. Is there any settings I need to make on Tomcat as I am new to Tomcat so have no idea where to look.

Any help is appreciated.

Thanks
 
William Brogden
Author and all-around good cowpoke
Rancher
Posts: 13074
6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
If I try to invoke a Web Service I get an error message


What is the content of the error message?

How is tomcat installed - service style or as application?

How is Tomcat started?

Will other Tomcat pages respond after the web service stops working?

Does the web service depend on a database connection that might be getting closed?

Bill
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic