• Post Reply Bookmark Topic Watch Topic
  • New Topic

Bad Version Number when deploying app

 
Henrique Ordine
Ranch Hand
Posts: 129
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Dear ranchers:

When trying to deploy my application on tomcat 5.5 I get the following error:
SEVERE: Error configuring application listener of class br.gov.fazenda.ouvidoria.sisouvidor.listener.ApplicationListener
java.lang.UnsupportedClassVersionError: Bad version number in .class file

I was compiling my application using JDK 1.6 but I changed that to 1.5.0_11, which is the same as the one my tomcat server is using. I'm still getting the same error.
Could anyone tell me if there is anything else that causes this error?
 
Seetharaman Venkatasamy
Ranch Hand
Posts: 5575
Eclipse IDE Java Windows XP
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Originally posted by Henrique Ordine:

java.lang.UnsupportedClassVersionError: Bad version number in .class file


-------------------------------------------------------------------
i think you are using different jdk and jre version...
----------------------------------------------------------------------


one more question to you why you change your .class files from 1.6 to 1.5
-----------------------------------------
you can use jdk 1.6 to tomcat5.5
------------------------------------------

correct me ,if i am wrong
 
Happiness is not a goal ... it's a by-product of a life well lived - Eleanor Roosevelt. Tiny ad:
the new thread boost feature: great for the advertiser and smooth for the coderanch user
https://coderanch.com/t/674455/Thread-Boost-feature
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!