This week's book giveaway is in the Spring forum.
We're giving away four copies of Spring Boot in Practice and have Somnath Musib on-line!
See this thread for details.
Win a copy of Spring Boot in Practice this week in the Spring forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Tim Cooke
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Liutauras Vilda
  • Henry Wong
  • Devaka Cooray
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • Al Hobbs
  • Carey Brown
Bartenders:
  • Piet Souris
  • Mikalai Zaikin
  • Himai Minh

Is there something wrong with this .ear archive?

 
Ranch Hand
Posts: 1561
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi guys. I'm having a problem deploying an ear file in JBoss.

application.xml defines the three modules I have in the EAR file (two beans and 1 java -client.jar)
1o.) entity.jar:
It's got the 3 classes needed for this entity bean. Plus the manifest, ejb-jar.xml and JBoss.xml (do I need Jboss.xml in this jar??
my ejb-jar.xml is:

2o.) client.jar
the client is a java class that connects to the session bean. I have an application-client.xml file inside it, which references the session bean. I do not have JBoss.xml in this jar (not quite sure about this...)
3o.) userMgmt.jar
3 java classes that compose the session bean, a manifest, ejb-jar.xml, and jboss.xml (not quite sure if I should place jboss.xml here)
The error I'm getting is the following:

what I understand is that if I have, for example, 3 ejb jar files I should have 3 ejb-jar.xml files,right?
and what about the JBoss.xml?? should it be on the root of my EAR file??
any help is highly appreciated
thanks
 
Andres Gonzalez
Ranch Hand
Posts: 1561
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I corrected some errors. I'm using ant and was putting the xml files in a wrong directory. I put them in meta-inf\ and cleaned couple of errors. Now I'm only getting this one:

my application-client.xml is:

any ideas??
 
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
hi
did u happen to fix the problem for this,i so pleaze help me out
email:hgazzala@macess.com
 
Author
Posts: 367
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
You should post your application.xml.
reply
    Bookmark Topic Watch Topic
  • New Topic