Win a copy of Rust Web Development this week in the Other Languages forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Tim Cooke
  • Campbell Ritchie
  • Ron McLeod
  • Liutauras Vilda
  • Jeanne Boyarsky
Sheriffs:
  • Junilu Lacar
  • Rob Spoor
  • Paul Clapham
Saloon Keepers:
  • Tim Holloway
  • Tim Moores
  • Jesse Silverman
  • Stephan van Hulst
  • Carey Brown
Bartenders:
  • Al Hobbs
  • Piet Souris
  • Frits Walraven

JBoss debug

 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I'm using JBuilder and the problem I'm having is if I use the debugger I always have to restart the server before debugging again, occasionally it's necessary to restart before running anything again. Is there way to avoid this frequent restart of the server?
 
Ranch Hand
Posts: 47
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi, Perry!
Please describe your problem in details. Why do you need to restart you app. server to run your application for debugging again?
Regards, Volodymyr Shram.
 
Ranch Hand
Posts: 190
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I'm having the same problem. There could be many problems if I don't restart my JBoss after a recompilation and redeploy. First, I might get a ClassCastException when my struts classes calls the home interface of my EJB, etc.

Second, sometimes I got error like this:


I suspect that somehow the app server and the web server think that they are not using the same version of source codes even though they are.

Any solution would be very much appreciated. This restarting thing is robbing me of my time.

Originally posted by Volodymyr Shram:
Hi, Perry!

Please describe your problem in details. Why do you need to restart you app. server to run your application for debugging again?

Regards, Volodymyr Shram.


[ April 13, 2005: Message edited by: Ken Loh ]
 
reply
    Bookmark Topic Watch Topic
  • New Topic