Win a copy of The Way of the Web Tester: A Beginner's Guide to Automating Tests this week in the Testing forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

JBOSS and tiles

B Rook
Posts: 13
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I'm getting a tiles error when upgrading from 3.0.8 to 3.2.5. On 3.0.8, this would only cause a warning, but on 3.2.5 this causes a full error that stops the application. It looks like the problem is with the tiles:include tag. Whenever this tag is used, we get an error like this:

(On the actual page in the browser)
[ServletException in:/WEB-INF/jsp/LoggedUserLayout.jsp] org.apache.struts.taglib.EnumerateTei'

(From the stack trace)
15:09:11,218 ERROR [Engine] ApplicationDispatcher[/siteuser] Servlet.service() for servlet jsp threw exception
java.lang.ClassNotFoundException: org.apache.struts.taglib.EnumerateTei
at Method)
(further down...)
at org.apache.struts.taglib.tiles.InsertTag.doInclude(
at org.apache.struts.taglib.tiles.InsertTag$InsertHandler.doEndTag(
at org.apache.struts.taglib.tiles.InsertTag.doEndTag(
at org.apache.jsp.WEB_002dINF.jsp.overview.CSEWorkerIndex_jsp._jspx_meth_tiles_insert_0(
at org.apache.jsp.WEB_002dINF.jsp.overview.CSEWorkerIndex_jsp._jspService(

Struts.jar (version 1.1) is in the WEB-INF/lib directory and not in the container lib directory. Here is the code from the .jsp:

<%@ taglib uri="/WEB-INF/struts-tiles.tld" prefix="tiles" %>
<%@ taglib uri="/WEB-INF/struts-html.tld" prefix="html" %>
<td valign="top">
<tiles:insert attribute="body"/>
<!-- End Main Content Here -->

Does anyone have a suggestion as to what is the cause?


  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic