• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Junilu Lacar
Sheriffs:
  • Rob Spoor
  • Liutauras Vilda
  • Tim Cooke
Saloon Keepers:
  • Tim Moores
  • Piet Souris
  • Tim Holloway
  • Jj Roberts
  • Stephan van Hulst
Bartenders:
  • Himai Minh
  • Carey Brown
  • Frits Walraven

Can't Debug JBoss in Eclipse w. Lomboz

 
Greenhorn
Posts: 14
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Dear all,

I am trying "MyJ2EEProject" tutorial provided by Lomboz (see : http://www.objectlearn.com/support/docs/firstWebApplication.jsp) ;

I am working ('mean I try !) with eclipse 3.0.1 and JBoss 4.0.0 ; I added a file jboss400.server within the Lomboz plugin directory "com.objectlearn.jdt.j2ee_3.0.1\servers" as recommended in one of the numerous discussions dealing with this frequent issue in JavaRanch: I downloaded the source file from a recommended Japanese Site ;

Finally I could create my J2EE project but now I can't run debug the apps : JBoss Server does not run ! The eclipse console remains blank, and the perspective does not switch to the debug view !

Herebelow is my jboss400.server file.

Thanks for help
Regards
Laurent

jboss400.server :

<serverDefinition
name="JBOSS 4.0.0"
ejbModules="true"
webModules="true"
earModules="true">
<property id="serverRootDirectory"
label="Application Server Directory:"
type="directory"
default="C:/Java/jboss-4.0.0" />
<property id="serverAddress"
label="Address:"
type="string"
default="127.0.0.1" />
<property id="serverPort"
label="Port:"
type="string"
default="8080" />
<property id="serverConfig"
label="Server Configuration (standard/minimal/default/all):"
type="string"
default="standard" />
<property id="classPathVariableName"
label="Classpath Variable Name:"
type="string"
default="JBOSS400" />
<property id="classPath"
label="Classpath Variable:"
type="directory"
default="C:/Java/jboss-4.0.0" />
<serverHome>${serverRootDirectory}</serverHome>
<webModulesDeployDirectory>${serverRootDirectory}/server/${serverConfig}/deploy</webModulesDeployDirectory>
<ejbModulesDeployDirectory>${serverRootDirectory}/server/${serverConfig}/deploy</ejbModulesDeployDirectory>
<earModulesDeployDirectory>${serverRootDirectory}/server/${serverConfig}/deploy</earModulesDeployDirectory>
<jndiInitialContextFactory>org.jnp.interfaces.NamingContextFactory</jndiInitialContextFactory>
<jndiProviderUrl>jnp://${serverAddress}:1099</jndiProviderUrl>;
<startClass>org.jboss.Main</startClass>
<startWorkingDirectory>${serverRootDirectory}/bin</startWorkingDirectory>
<startVmParameters>-Djava.endorsed.dirs=${serverRootDirectory}/lib/endorsed</startVmParameters>
<startProgramArguments>-c ${serverConfig}</startProgramArguments>
<stopClass>org.jboss.Shutdown</stopClass>
<stopWorkingDirectory>${serverRootDirectory}/bin</stopWorkingDirectory>
<stopVmParameters></stopVmParameters>
<stopProgramArguments>-S</stopProgramArguments>
<serverClassPath>
<jar type="variable">JDK_TOOLS</jar>
<jar type="variable">${classPathVariableName}/bin/run.jar</jar>
<jar type="variable">${classPathVariableName}/bin/shutdown.jar</jar>
<jar type="variable">${classPathVariableName}/lib/concurrent.jar</jar>
<jar type="variable">${classPathVariableName}/lib/dom4j.jar</jar>
<jar type="variable">${classPathVariableName}/lib/gnu-regexp.jar</jar>
<jar type="variable">${classPathVariableName}/lib/jboss-jmx.jar</jar>
<jar type="variable">${classPathVariableName}/lib/jboss-common.jar</jar>
<jar type="variable">${classPathVariableName}/lib/jboss-system.jar</jar>
<jar type="variable">${classPathVariableName}/lib/endorsed/xercesImpl.jar</jar>
<jar type="variable">${classPathVariableName}/lib/endorsed/xml-apis.jar</jar>
<jar type="variable">${classPathVariableName}/server/${serverConfig}/lib/activation.jar</jar>
<jar type="variable">${classPathVariableName}/server/${serverConfig}/lib/avalon-framework.jar</jar>
<jar type="variable">${classPathVariableName}/server/${serverConfig}/lib/bcel.jar</jar>
<jar type="variable">${classPathVariableName}/server/${serverConfig}/lib/bsh-commands-1.3.0.jar</jar>
<jar type="variable">${classPathVariableName}/server/${serverConfig}/lib/bsh-core-1.3.0.jar</jar>
<jar type="variable">${classPathVariableName}/server/${serverConfig}/lib/bsh-deployer.jar</jar>
<jar type="variable">${classPathVariableName}/server/${serverConfig}/lib/castor-0.9.3.9-xml.jar</jar>
<jar type="variable">${classPathVariableName}/server/${serverConfig}/lib/cglib-full-2.0.1.jar</jar>
<jar type="variable">${classPathVariableName}/server/${serverConfig}/lib/hibernate2.jar</jar>
<jar type="variable">${classPathVariableName}/server/${serverConfig}/lib/hsqldb.jar</jar>
<jar type="variable">${classPathVariableName}/server/${serverConfig}/lib/hsqldb-plugin.jar</jar>
<jar type="variable">${classPathVariableName}/server/${serverConfig}/lib/jacorb.jar</jar>
<jar type="variable">${classPathVariableName}/server/${serverConfig}/lib/javax.servlet.jar</jar>
<jar type="variable">${classPathVariableName}/server/${serverConfig}/lib/javax.servlet.jsp.jar</jar>
<jar type="variable">${classPathVariableName}/server/${serverConfig}/lib/jaxr-client.jar</jar>
<jar type="variable">${classPathVariableName}/server/${serverConfig}/lib/jboss.jar</jar>
<jar type="variable">${classPathVariableName}/server/${serverConfig}/lib/jboss-common-jdbc-wrapper.jar</jar>
<jar type="variable">${classPathVariableName}/server/${serverConfig}/lib/jboss-hibernate.jar</jar>
<jar type="variable">${classPathVariableName}/server/${serverConfig}/lib/jboss-iiop.jar</jar>
<jar type="variable">${classPathVariableName}/server/${serverConfig}/lib/jboss-j2ee.jar</jar>
<jar type="variable">${classPathVariableName}/server/${serverConfig}/lib/jboss-jaxrpc.jar</jar>
<jar type="variable">${classPathVariableName}/server/${serverConfig}/lib/jboss-jca.jar</jar>
<jar type="variable">${classPathVariableName}/server/${serverConfig}/lib/jboss-jsr77.jar</jar>
<jar type="variable">${classPathVariableName}/server/${serverConfig}/lib/jboss-management.jar</jar>
<jar type="variable">${classPathVariableName}/server/${serverConfig}/lib/jboss-monitoring.jar</jar>
<jar type="variable">${classPathVariableName}/server/${serverConfig}/lib/jboss-saaj.jar</jar>
<jar type="variable">${classPathVariableName}/server/${serverConfig}/lib/jboss-transaction.jar</jar>
<jar type="variable">${classPathVariableName}/server/${serverConfig}/lib/jbossmq.jar</jar>
<jar type="variable">${classPathVariableName}/server/${serverConfig}/lib/jbosssx.jar</jar>
<jar type="variable">${classPathVariableName}/server/${serverConfig}/lib/jnpserver.jar</jar>
<jar type="variable">${classPathVariableName}/server/${serverConfig}/lib/jpl-pattern.jar</jar>
<jar type="variable">${classPathVariableName}/server/${serverConfig}/lib/jpl-util.jar</jar>
</serverClassPath>
<clientClassPath>
<jar type="variable">${classPathVariableName}/client/jboss-j2ee.jar</jar>
<jar type="variable">${classPathVariableName}/client/jboss-common-client.jar</jar>
<jar type="variable">${classPathVariableName}/client/jbossall-client.jar</jar>
<jar type="variable">${classPathVariableName}/client/jbosssx-client.jar</jar>
<jar type="variable">${classPathVariableName}/client/jnp-client.jar</jar>
<jar type="variable">${classPathVariableName}/client/log4j.jar</jar>
<jar type="variable">${classPathVariableName}/server/default/lib/jnpserver.jar</jar>
</clientClassPath>
<projectClassPath>
<jar type="variable">JDK_TOOLS</jar>
<jar type="variable">${classPathVariableName}/bin/run.jar</jar>
<jar type="variable">${classPathVariableName}/bin/shutdown.jar</jar>
<jar type="variable">${classPathVariableName}/client/jboss-j2ee.jar</jar>
<jar type="variable">${classPathVariableName}/lib/concurrent.jar</jar>
<jar type="variable">${classPathVariableName}/lib/jboss-system.jar</jar>
<jar type="variable">${classPathVariableName}/server/${serverConfig}/lib/bcel.jar</jar>
<jar type="variable">${classPathVariableName}/server/${serverConfig}/lib/javax.servlet.jar</jar>
<jar type="variable">${classPathVariableName}/server/${serverConfig}/lib/jboss.jar</jar>
<jar type="variable">${classPathVariableName}/server/${serverConfig}/lib/jboss-transaction.jar</jar>
<jar type="variable">${classPathVariableName}/server/${serverConfig}/lib/jnpserver.jar</jar>
<jar type="variable">${classPathVariableName}/server/${serverConfig}/lib/jpl-pattern.jar</jar>
<jar type="variable">${classPathVariableName}/server/${serverConfig}/lib/jpl-util.jar</jar>
</projectClassPath>
<adminTool>
<web><deploy /><undeploy />
</web>
<ejb><deploy /><undeploy />
</ejb>
<ear><deploy /><undeploy />
<webModule><deploy /><undeploy />
</webModule>
<ejbModule><deploy /><undeploy />
</ejbModule>
</ear>
</adminTool>
<adminToolPath>
</adminToolPath>
</serverDefinition>
 
Laurent Salse
Greenhorn
Posts: 14
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I finally solve the problem :
I re-installed JBoss-4.0.0 (I had "corrupted" I guess with my numerous "flip-fop" in configuration settings ;

I also changed the configuration of the Server in Eclipse under Windows > Preferences > Lomboz > Server Definition ; I set "Default" instead of standard.

Then I could run the Lomboz tutorial one more step beyond !
 
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,

I am facing the same problem. Did you do anything other than re-installing jboss?
 
Laurent Salse
Greenhorn
Posts: 14
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Actually, as far as I can remember I did not change anythingelse ; nevertheless, I advise you to set a "clean" install of Eclipse+Lomboz+JBoss configuration before running eclipse for the first time !

With Eclipse 3.0.1 I experienced that to make it run with a new plugin I had to re-install Eclipse and all the other plugins along before running this "new" Eclipse.

Then, you can try to re-install eclipse and then before running eclipse re-install Lomboz Plugin, copy the file jboss400.server (and this is tricky in fact ; do you find it back in the Lomboz "Preference" configuration ? on my side I had to change an existing one ...) in the proper plugin directory, re-install JBoss 4.0.0 (the previous deployments of your J2EE projects might cause troubles when starting the server ...) ; this worked for me, but I did this 3 or 4 times in a single day !

Let me know how you got out of this !
 
NSK SK
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hey Laurent,

Thanks for your reply. I did a reinstall of everything and its working just great now.

Thank you
 
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
hi

oh,just reinstall,everything is ok?

let me try it !!!

any way, thanks

 
There are 10 kinds of people in this world. Those that understand binary get this tiny ad:
Thread Boost feature
https://coderanch.com/t/674455/Thread-Boost-feature
reply
    Bookmark Topic Watch Topic
  • New Topic