Win a copy of Functional Reactive Programming this week in the Other Languages forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

NoClassDefFoundError on client side

 
Gerald Holl
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello!

I deployed some EJB3 session beans with JBoss 4.0.3RC1 without errors but I always get a NoClassDefFoundError when I call a method on the client.
Here are some lines of the (console) test client:


The getSubsriptionId() Method returns a simple string. The lookup works fine.

RemoteSearch is the remote interface that the session bean implements.

Here is the whole error:


I didn't find any hints with google, I hope somebody can help me.

cheers,
Gerald
 
Gerald Holl
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Sorry, I've forgotten the most important part :roll:

The getSubscriptionId() method should return a String (it doesn't). It's the point where error occurs.
 
norman richards
Author
Ranch Hand
Posts: 367
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You should post this on the JBoss forums. I don't know if you have simply not included the correct jars on the classpath or of the client jars in 4.0.3RC1 aren't uptodate. But, you can probably get faster help there.
 
Gerald Holl
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello Norman,

I solved it with help from the JBoss forum:
The file common-httpclient.jar was missing.

Anyway, the response time in this forum is quite faster than of the JBoss forum, that's the reason why I prefer posting here
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic