• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

please help me to run a conatimer managed bean with Jboss

Jasmine kaur
Ranch Hand
Posts: 160
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi everybody ,
I have made all the ejbs files and using MySql as a database with Jboss4.0.
I downloaded the mysql-connector-java-3.1.7-bin.jar and put into the D:\jboss\server\default\lib folder.

After this I configured the follwing files
like this

1) ejb-jar.xml
<?xml version="1.0"?>

"-//Sun Microsystems, Inc.//DTD Enterprise JavaBeans 2.0//EN"


<description>My CMP</description>

2) jboss.xml
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE jboss PUBLIC "-//JBoss//DTD JBOSS//EN" "http://www.jboss.org/j2ee/dtd/jboss.dtd">







3) Third file is standardjbosscmp-jdbc.xml

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE jbosscmp-jdbc PUBLIC

<!-- ===================================================================== -->
<!-- -->
<!-- Standard JBossCMP-JDBC Configuration -->
<!-- -->
<!-- ===================================================================== -->

<!-- $Id: standardjbosscmp-jdbc.xml,v 1.73 2004/02/06 15:06:00 loubyansky Exp $ -->




But my program is not running and at server Iam getting exception.Could you please tell me is am mising something or not .
I also try on http://localhost:8080/jmx-console/HtmlAdaptor and give the namme of the driver also but iam getting this message on the jboss server

com.mysql.jdbc.Driver Information
Not loaded in repository cache

### Instance0 found in UCL: org.jboss.mx.loading.UnifiedClassLoader3@15bdc50{ url=file:/D:/jboss/server/default/tmp/deploy/tmp59879jboss-service.xml ,addedOrder=2}

whivh show server is not able to load driver class.
so please tell me where Iam wrong and what should I configure more.
Thanks in advance.
Heonkoo Lee
Ranch Hand
Posts: 85
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Try to add the jdbc jar to the JBOSS_CLASSPATH environment variable in run.bat.


Also, change the jndi-name for your bean in the jboss.xml because it is the same as your ejb-name. And 'cmp' as ejb-name doesn't look so good even if it doesn't cause any problem.

Good luck.
[ October 10, 2005: Message edited by: Heonkoo Lee ]
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic