• Post Reply Bookmark Topic Watch Topic
  • New Topic

PDF upload content type is application/x-download  RSS feed

Kem Broder
Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Just realised I'm having this problem and the weird thing is it worked before. I just can't figure out what I've done to break my app.
I'm uploading a file and need to inspect the content type to work out what I want to do with it. PDF files had been uploading fine with the content type as application/pdf. However, I've found that now they are uploading with the content type application/x-download.

I've tried various things, adding a mime mapping to the web.xml, checked the mime-types in my web server, run straight against my app server, but the problem persists. Has anyone any ideas why the content type is showing up as something other than what it is?

It is sorta covered in the JavaRanch Style Guide.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!