Win a copy of The Java Performance Companion this week in the Performance forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Eclipse plug-in for JBOSS

 
Poornima Shankar
Greenhorn
Posts: 28
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Which Eclipse plug-in for JBOSS to use, I need to debug
 
Jaikiran Pai
Marshal
Pie
Posts: 10447
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
What do you want to debug? You dont require any plugins in Eclipse to debug applications running on JBoss(or any other application server). Eclipse has the "Debug - Remote Applications" feature which you can use for debugging applications running on a server.
 
Mark Spritzler
ranger
Sheriff
Posts: 17278
6
IntelliJ IDE Mac Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
And if you go to the run.bat file in the <JBOSS_INSTALL_DIR>\bin and edit it with any editor, there is a commented line that will set JBoss to be in "debug" mode, just uncomment it out and JBoss will listen to port 8787, but you can change the port number if you want. Also change the "suspend=y" to "suspend=n"

Mark
 
D. Clarke
Greenhorn
Posts: 25
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I tried using the JBoss-IDE plugin so that I could debug my applications on JBoss. However, it didn't even come close to working. I am trying to find directions how to configure Eclipse to debug my app, but haven't found a set yet (there seem to be discrepencies between the documentation and my Eclipse 3.2 on OS X).

I have read that you should be able to have the Eclipse debugger start the JBoss main class and that is one way. Not sure about the port you need (if default was 8080 do you now go to 8787?).

Anyway, I guess my point is that there are plugins that are supposed to work - myEclipse and JBoss being two of them.
 
Paul Sturrock
Bartender
Posts: 10336
Eclipse IDE Hibernate Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

However, it didn't even come close to working.

Works fine for me. What went wrong?

Jaikiran Pai and Mark Spritzler have given a way to do this without any IDE - by using Remote Debugging. Have you tried that?
 
D. Clarke
Greenhorn
Posts: 25
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I don't really have any problem using the JBoss-IDE plugin, it's just that after installing on my OS X (10.4.8) nothing at all happens. It can't find any projects to associate with, even tho I have several J2EE projects.

I have installed/uninstalled/reinstalled the JBoss-IDE plugin several times as the online documentation called for. When restarting Eclipse and then selecting "Run | Debug" I get a screen asking me to provide the projects that will be used. The list is null, so I can only assume the plugin either can't see or doesn't recognize my applications (standard Eclipse Java project).

When I try to configure a server to debug with, clicking the new button doesn't give any options.

All I can guess is that this won't work on OS X (10.4.8) with Eclipse (3.2) and JBoss AS 4.0.2, with JBoss IDE 1.6.0.GA.

I don't have to use the JBoss-IDE, but I haven't been able to get Eclipse set up to debug either. I do have myEclipse installed, but because of the way my application is structured (one application instead of many webapp/EJB) it won't work for me.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic