Win a copy of Kotlin in Action this week in the Kotlin forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

[JBOSS 4.2] startup failed with Eclipse 3.3 Europa  RSS feed

 
Celinio Fernandes
Ranch Hand
Posts: 549
Eclipse IDE Google Web Toolkit Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
I get the following error message when i try to startup JBOSS 4.2

java.lang.UnsupportedClassVersionError: javax/management/NotificationEmitter (Unsupported major.minor version 49.0)


My environement :
Eclipse 3.3 Europa
Installed JRE: j2sdk1.4.2_05

I am trying to launch JBoss 4.2 with the JDK 1.4.2.
JBoss 4.2 is fully compatible with JDK 1.4.2.
So what is the problem?

Thanks for helping
 
Jaikiran Pai
Sheriff
Posts: 10447
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You cant run JBoss-4.2.x with JDK1.4.x. You need to have Java 5 for JBoss4.2.x. You can find the details at JBossVsJavaJDKVersionMatrix
 
Don't get me started about those stupid light bulbs.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!