• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Tim Cooke
  • Paul Clapham
  • Devaka Cooray
  • Bear Bibeault
Sheriffs:
  • Junilu Lacar
  • Knute Snortum
  • Liutauras Vilda
Saloon Keepers:
  • Ron McLeod
  • Stephan van Hulst
  • Tim Moores
  • Tim Holloway
  • Piet Souris
Bartenders:
  • salvin francis
  • Carey Brown
  • Frits Walraven

JBoss seam example apps

 
Ranch Hand
Posts: 118
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I installed JBoss seam, the JBoss server, and ANT, and I configured them ok.
Then I went to the examples directory in seam, and in the particular application subdirectory (booking), I typed ant-deploy.
Then I pointed my browser to http://localhost:8080/seam-booking
And I ended up with this error:

error 404, the requested resource is not available.
I checked the build.properties file, and Its pointing to the JBoss AS directory...I set it like this:

jboss.home D:\\Program Files\\jboss-4.0.5.GA

Can anyone help or at least tell me why the applications dont work?

Regards
 
Greenhorn
Posts: 12
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Adewale,

I just did what you did and it works!! What version of Seam and JBoss server are you using? I am using jboss-4.2.2.GA and jboss-seam-2.0.0.GA. There might be a version compatibility problem here.

I hope this helps.

Wayne Hatayama
 
clojure forum advocate
Posts: 3479
Mac Objective C Clojure
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Maybe you are missing "=" from your:
jboss.home D:\\Program Files\\jboss-4.0.5.GA
??
What is your JBoss AS version?
 
Adewale Adebusoye
Ranch Hand
Posts: 118
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am using JBoss 4.0.5.GA and JBoss seam 2.0.0 GA and Ant 1.7..And I put an "=" in the build.config.
 
Adewale Adebusoye
Ranch Hand
Posts: 118
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
And yesss I changed my JBoss version to 4.2.2.GA and properly edited the build.properties file, and it worked!!! Thanks guys, like wayne said, probably a version compatibility error.
Now I can go to bed.
Thanks guys!!
 
Enjoy the full beauty of the english language. Embedded in this tiny ad:
Java file APIs (DOC, XLS, PDF, and many more)
https://products.aspose.com/total/java
    Bookmark Topic Watch Topic
  • New Topic