• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

jboss-eap-4.3 running default server JARDeployer fails

 
Diego Bowen
Ranch Hand
Posts: 50
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello all, I'm new to JBoss and I've installed Jboss-eap-4.3 and I'm attempting to run the default server...however i'm getting a lot of the the following:


15:46:52,569 WARN [JARDeployer] Failed to add deployable jar: file:/usr/local/jboss-eap-4.3/jboss-as/server/default/tmp/deploy/tmp22658._jboss-annotations-ejb3.jar
java.util.zip.ZipException: error in opening zip file
at java.util.zip.ZipFile.open(Native Method)


resulting in a lot of these:

--- Incompletely deployed packages ---
org.jboss.deployment.DeploymentInfo@3adf93c3 { url=file:/usr/local/jboss-eap-4.3/jboss-as/server/default/deploy/jboss-messaging.sar/._connection-factories-service.xml }
deployer: org.jboss.deployment.SARDeployer@1309e87
status: null
state: FAILED
watch: file:/usr/local/jboss-eap-4.3/jboss-as/server/default/deploy/jboss-messaging.sar/._connection-factories-service.xml
altDD: null
lastDeployed: 1218667614574
lastModified: 1218667614000
mbeans:

org.jboss.deployment.DeploymentInfo@31464888 { url=file:/usr/local/jboss-eap-4.3/jboss-as/server/default/deploy/jboss-messaging.sar/ }
deployer: org.jboss.deployment.SARDeployer@1309e87
status: null
state: FAILED
watch: file:/usr/local/jboss-eap-4.3/jboss-as/server/default/deploy/jboss-messaging.sar/META-INF/jboss-service.xml
altDD: null
lastDeployed: 1218667614574
lastModified: 1199400610000
mbeans:

org.jboss.deployment.DeploymentInfo@94a9ff6a { url=file:/usr/local/jboss-eap-4.3/jboss-as/server/default/deploy/jbossws.sar/._jbossws.beans }
deployer: org.jboss.kernel.deployment.jboss.JBossBeanDeployer@158cc6
status: null
state: FAILED
watch: file:/usr/local/jboss-eap-4.3/jboss-as/server/default/deploy/jbossws.sar/._jbossws.beans
altDD: null
lastDeployed: 1218667614594
lastModified: 1218667614000
mbeans:

org.jboss.deployment.DeploymentInfo@fe114543 { url=file:/usr/local/jboss-eap-4.3/jboss-as/server/default/deploy/jbossws.sar/ }
deployer: org.jboss.deployment.SARDeployer@1309e87
status: null
state: FAILED
watch: file:/usr/local/jboss-eap-4.3/jboss-as/server/default/deploy/jbossws.sar/META-INF/jboss-service.xml
altDD: null
lastDeployed: 1218667614595
lastModified: 1199400612000
mbeans:

org.jboss.deployment.DeploymentInfo@62029671 { url=file:/usr/local/jboss-eap-4.3/jboss-as/server/default/deploy/management/console-mgr.sar/._console-mgr-classes.jar }
deployer: null
status: null
state: FAILED
watch: file:/usr/local/jboss-eap-4.3/jboss-as/server/default/deploy/management/console-mgr.sar/._console-mgr-classes.jar
altDD: null
lastDeployed: 1218667614621
lastModified: 1218667614000
mbeans:

org.jboss.deployment.DeploymentInfo@e821be3c { url=file:/usr/local/jboss-eap-4.3/jboss-as/server/default/deploy/management/console-mgr.sar/ }
deployer: org.jboss.deployment.SARDeployer@1309e87
status: null
state: FAILED
watch: file:/usr/local/jboss-eap-4.3/jboss-as/server/default/deploy/management/console-mgr.sar/META-INF/jboss-service.xml
altDD: null
lastDeployed: 1218667614621
lastModified: 1199400608000
mbeans:

Would appreciate any help thanks
 
Peter Johnson
author
Bartender
Posts: 5852
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Diego and I are working this issue in another location - will post final solution when we have it.
 
Tom Lichtenberg
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I'm coming across exactly this issue with JBoss-4.2.2-GA - If someone did find the solution I'd be glad to see it. I'm required to use this version for a specific deployment
Thanks
 
Diego Bowen
Ranch Hand
Posts: 50
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Someone else is asking me about this and I was wondering if the solution was ever posted as well. Thanks
 
Peter Johnson
author
Bartender
Posts: 5852
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Here is the discussion we had: http://www.jboss.org/index.html?module=bb&op=viewtopic&t=140807

I think the issue was due to using FTP to transfer the ZIP file in text mode rather than in binary mode.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic