Win a copy of Murach's Python Programming this week in the Jython/Python forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

Regarding Sun Java System Application Server9.1 Issue with JVM5  RSS feed

gagan narula
Posts: 18
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Regarding Sun Java System Application Server Issue with JVM


I have installed SJSAS9.1 on solaris system. I m trying to deploy war file which i compiled in windows enviorment by jdk1.5.0_05. Every time i got the following error :

type Exception report


descriptionThe server encountered an internal error () that prevented it from fulfilling this request.


org.apache.jasper.JasperException: PWC6033: Unable to compile class for JSP

PWC6199: Generated servlet error:
[javac] javac: invalid target release: 1.5
[javac] Usage: javac
[javac] where possible options include:
[javac] -g Generate all debugging info
[javac] -g:none Generate no debugging info
[javac] -g:{lines,vars,source} Generate only some debugging info
[javac] -nowarn Generate no warnings
[javac] -verbose Output messages about what the compiler is doing
[javac] -deprecation Output source locations where deprecated APIs are used
[javac] -classpath Specify where to find user class files
[javac] -sourcepath Specify where to find input source files
[javac] -bootclasspath Override location of bootstrap class files
[javac] -extdirs Override location of installed extensions
[javac] -d Specify where to place generated class files
[javac] -encoding Specify character encoding used by source files
[javac] -source Provide source compatibility with specified release
[javac] -target Generate class files for specific VM version
[javac] -help Print a synopsis of standard options

note The full stack traces of the exception and its root causes are available in the Sun Java System Application Server 9.1 logs.

I have cheked jvm version on both system the only difference is :

Solaris points to jdk 1.5.0_09
Windows point to jdk1.5.0_05

Even i tried to run blank jsp also but again i got the same error.

Can any help me to sort out the problem or give me any idea so i can do something by my own.

Thanks in Advance

It is sorta covered in the JavaRanch Style Guide.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!