• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Jeanne Boyarsky
  • Tim Cooke
Sheriffs:
  • Liutauras Vilda
  • paul wheaton
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Tim Holloway
  • Stephan van Hulst
  • Carey Brown
  • Frits Walraven
Bartenders:
  • Piet Souris
  • Himai Minh

Proxi-pattern and RMI question?

 
Ranch Hand
Posts: 76
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I cant get this simplest Proxi-pattern and RMI example from HFDP pages 441 to 446 working. This is what I have done:

1. created remote Interface

2. created remote Implementation

3. created client

4. compiled all three classes and created stubs and started rmiregistry
C:\eclipse21\workspace\rmiTest>rmic de.mediaholic.rmi.MyRemoteImpl
Rmiregistry

5. opened onother cmd and started remote service
C:\eclipse21\workspace\rmiTest>java de.mediaholic.rmi.MyRemoteImpl

Now when I run my RmiTestMain it doesn�t output anything? No errors, no string hallo, simply nothing???
What is wrong? Is there any tool whit i can debug this rmi? For example to see what services r registred?

Cann anyone help?
i m running on w2k sp3, j2sdk1.4.2.0.9
[ November 02, 2005: Message edited by: Ner min ]
 
This is my favorite tiny ad:
Free, earth friendly heat - from the CodeRanch trailboss
https://www.kickstarter.com/projects/paulwheaton/free-heat
reply
    Bookmark Topic Watch Topic
  • New Topic