The way I see it now, if your javabean needs to register a Listener, the JavaBeans naming standard requires add and remove methods to be named with a prefix of 'add' and 'remove' respectively, followed by the name of the Listener. Now the tricky part that I couldn't find info on until Satou pointed me at the JavaBeans spec, is that Listeners themselves also have a naming standard stipulated by the JavaBeans API spec. That is, "where the �<EventListenerType>� type name ends with �Listener�." as stated in Section 8.4.
To relate it back to the question from the book (see previous post), 'addSize' does not fit this 'Design Pattern'/naming convention. Sure it has a prefix of 'add', but if 'Size' is a Listener (which it could be if you view it as a verb instead of a noun), it does not conform to the naming convention. To do so it would need to be named 'SizeListener'.
It's actually worth reading all of section 8 in the spec to get the reasoning behind the naming conventions. I won't reiterate it here, I'll leave that for readers to do in their spare time.
But it's titled 'Introspection' and covers naming conventions for properties, events and methods.
In summary, I think the JavaBeans API spec is the ultimate source of information on this subject. An interesting excercise is to do a search through the document for the phrases 'convention' and 'design pattern'. There are quite a few.
I think I've prattled on long enough now, so I'll leave it there.
Hope this helps,