mark jenkins

Greenhorn
+ Follow
since Feb 16, 2006
Cows and Likes
Cows
Total received
0
In last 30 days
0
Total given
0
Likes
Total received
0
Received in last 30 days
0
Total given
0
Given in last 30 days
0
Forums and Threads
Scavenger Hunt
expand Ranch Hand Scavenger Hunt
expand Greenhorn Scavenger Hunt

Recent posts by mark jenkins

You was right, there was something wrong with my tomcat setup. Therefore, I started over completely. I reinstalled Tomcat, reset my environment variables, and i placed a copy of the servlet.jar in my jre/ext folder and everything is working fine.

thanks for taking the time.
12 years ago
JSP
In order to use EL in a jsp, do you have to configure it in DD?
12 years ago
JSP
In my web-app, I have a regular DD, an html form, and a JSP.
Whenever I use the standard actions <jsp:useBean ../> and <jsp:getProperty ../>, my app works fine. But as soon as I use EL, that's when the error occurs.

Here's the details of my web-app:
(1) I'm using Tomcat 5
(2) the .html file that i'm using:
<html><body>
<form action="TB3.jsp">
<center>
Name: <input type="text" name="name"><br><br>
ID#: <input type="text" name="empID"><br> <br>
First Food: <input type="text" name="food"><br><br>
Second Food: <input type="text" name="food"><br><br>
<input type="submit">
</center></form></body></html>
(3)TB3.jsp:
<html><body>
Request param name is: ${param.name} <br>
Request param empID is: ${param.empID} <br>
Request param food is: ${param.food} <br>
First food request param: ${paramValues.food[0]} <br>
Second food request param: ${paramValues.food[1]} <br>
Request param name: ${paramValues.name[0]}
</body></html>
(4)The DD in which the servlet is not used:
<web-app ...>
<servlet>
<servlet-name>Ch 8</servlet-name>
<servlet-class>com.example.PersonServlet</servlet-class>
</servlet>
<servlet-mapping>
<servlet-name>Ch 8</servlet-name>
<url-pattern>/UserChoice.do</url-pattern>
</servlet-mapping>
</web-app>

Is there something i'm doing wrong when i deploy this?

thanks for taking the time
12 years ago
JSP
Hello, I'm a newbie to JSP's and I need help with the use of the EL. Whenever I try to use EL in my JSP's the "HTTP Status 500 error" appears. Is there something I'm doing wrong within the JSP itself? Is there a way I can resolve this problem?

thanks for taking the time
12 years ago
JSP