I work in a large group of Java web app developers and we, of course, insist on descriptive variable names in our Java code. Many of my coworkers assume that this naming standard applies for all of the languages in our stack. But my opinion is that because almost all js variables are local - and their complete lifespan can be viewed within a single block - using brief names not just acceptable, but preferable, as it reduces noise. By the nature of functional code, the variable's significance usually is internal to the function, or to the larger mathematical context, rather than to the business concept reflected by the program's design.
What is your advice regarding naming conventions for javascript variables?
Thanks,
Rick