Win a copy of Classic Computer Science Problems in Swift this week in the iOS forum!

Siphiwe Madi

Ranch Hand
+ Follow
since Aug 16, 2007
Cows and Likes
Cows
Total received
0
In last 30 days
0
Total given
0
Likes
Total received
0
Received in last 30 days
0
Total given
0
Given in last 30 days
0
Forums and Threads
Scavenger Hunt
expand Ranch Hand Scavenger Hunt
expand Greenhorn Scavenger Hunt

Recent posts by Siphiwe Madi

Hi,
I have checked my datasource, everything looks fine. Is there a place withing DB or App Server where I can turn auto-commit off?

Please assist - I have been stuck on trying to run chapter 2 using Oracle db ever since and time is running out on me

Help
Hi All,

I'm trying to run a simple example from Chapter 2 where the PlaceBidBean tries to persist a Bid object to the DB Table (BIDS),
however upon running the PlaceBidBeanClient to test the Session bean through ANT i get the following error:

run:
[echo] Executing client class
[java] javax.ejb.EJBException: nested exception is: <1.0.0.1.1 nonfatal general error> org.apache.openjpa.persistence.PersistenceException: Cannot set auto-commit mode when using distributed transactions
[java] <1.0.0.1.1 nonfatal general error> org.apache.openjpa.persistence.PersistenceException: Cannot set auto-commit mode when using distributed transactions
[java] at org.apache.openjpa.jdbc.meta.MappingTool.record(MappingTool.java:546)

[java] at weblogic.rmi.internal.BasicServerRef$BasicExecuteRequest.run(BasicServerRef.java:1040)
[java] at weblogic.work.ExecuteThread.execute(ExecuteThread.java:200)
[java] at weblogic.work.ExecuteThread.run(ExecuteThread.java:172)
[java] Caused by: java.lang.Exception: java.sql.SQLException: Cannot set auto-commit mode when using distributed transactions



And I cannot find a way that i can manually configure the JDBC Connection Pool to disable autocommit.

Can anyone please advice - i have searched the Net but there is no solution that i have successfully found.




Hi All,

Is the any performance drawbacks when defining a Logger variable using a static identifier vs. an instance variable?

Will this cause any performance issues example code below.

e.g.

Logger as static variable:


Logger as instance variable:


Hi all,

I have a log4j.properties file where i configure the different appenders for different applications so that each application logs on its own .log file.

The problem that i'm having with this is that the Log statements for 1 application are being logged onto a wrong .log file.
So log statements that are suppose to be logged into the file 'DataCalculatorPortlet.log' are being logged into the file DAOLayer.log

for example 1 application should log on its own log file e.g.:

application 1: /opt/Vignette/Env/Logs/DAOLayer/DAOLayer.log
application 2: /opt/Vignette/Env/Logs/DataCalculatorPortlet/DataCalculatorPortlet.log

therefore my log4j.properties looks like this:


Any advice on what i might be doing wrong?
Hi all,

I'm using WebLogic 10.0 Application server - and i'm trying to update a currently deployed shared library by updating
the application in order to deploy new changes. However i'm getting the error below and i click on the Finish button.

This was previously working fine, but now i cannot redeploy an application.

Any assistance would be appreciated.

Error Details:

weblogic.management.ManagementException: [Deployer:149089]An attempt was made to activate the application '' when retirement is in progress.
Message icon - Error Update operation failed - no deployments changed.
7 years ago
Hi Ranchers,

I'm working on a QA environment which consists of 2 main clustered Web servers (site A & site B), there is also a 3rd box which is an Apache redirect server
which simply redirects the request to either Site A or Site B.

The 2 main servers (i.e. A and B) run an Application Server where each has an web application which renders the site.

The problem i'm experiencing is that there is a JavaScript error showing at the bottom of the Window when accessing this same web page
via the Apache server which redirects to either Site A or Site B. However when i access the same page directly on either site A or site B - the
JavaScript error doesn't appear.

I have used IE8's Developer tools debugger to find the details of the JavaScript - and it the error that is reported is:
"Syntax error - 0, line 1 character 1" and when viewing the HTML source of the rendered web page - the first line on
source is:

<!DOCTYPE xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

What is puzzling me is that the error is not reported when accessing the visiting the web page directly on the main server boxes - but reported
when accessing via the Apache server.

What tool or mechanism can i use to try and discover the main problem (i need to know if this is code related or configuration issue). Any help appreciated.

Hi Guys,

I'm looking for a tool that i can use to Load Test one of my custom Java Application that is used by web applications
when deployed onto the Application Server (WebLogic).
I need to load test it to determine the number of TPS it can handle.

I need to load test this application separately in order to understand how much it can handle
and separate it from the calling applications - as when its load tested through other client applications
it is not easy to pinpoint if indeed it is the application that is slow.


I would appreciate any leads/info you can assist with.

Regards,
Siphiwe Madi
7 years ago
Hi All,

I'm trying to call a Web service from a JSP running inside a web application deployed on to Weblogic Application Server 10

The error stacktrace:

Failed to parse WSDL http://#.#.#.#:####/CBS_GetBasicSubscriberNetworkProfileAxisFix?WSDL weblogic.wsee.wsdl.WsdlException: Failed to read wsdl file from url due to -- weblogic.net.http.HttpUnauthorizedException: Proxy or Server Authentication Required

weblogic.wsee.jaxrpc.ServiceImpl.throwServiceException(ServiceImpl.java:169)
weblogic.wsee.jaxrpc.ServiceImpl.loadWsdlDefinition(ServiceImpl.java:477)
weblogic.wsee.jaxrpc.ServiceImpl.(ServiceImpl.java:114)
net.voda.portal.cbs.cbs_getbasicsubscribernetworkprofile.GetBasicSubscriberNetworkProfileEsbTransactionBindingQSService_Impl.(Unknown Source)
net.voda.portal.cbs.cbs_getbasicsubscribernetworkprofile.GetBasicSubscriberNetworkProfileEsbTransactionBindingQSService_Impl.(Unknown Source)
jsp_servlet._templates._template0007._ywsubqfaudtaquxauwecwstqqdesrxaq.__testwebcalls_dao._jspService(__testwebcalls_dao.java:148)
weblogic.servlet.jsp.JspBase.service(JspBase.java:34)
weblogic.servlet.internal.StubSecurityHelper$ServletServiceAction.run(StubSecurityHelper.java:226)
weblogic.servlet.internal.StubSecurityHelper.invokeServlet(StubSecurityHelper.java:124)
weblogic.servlet.internal.ServletStubImpl.execute(ServletStubImpl.java:283)
weblogic.servlet.internal.ServletStubImpl.onAddToMapException(ServletStubImpl.java:394)
weblogic.servlet.internal.ServletStubImpl.execute(ServletStubImpl.java:309)
weblogic.servlet.internal.TailFilter.doFilter(TailFilter.java:26)
weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:42)
com.vignette.portal.website.internal.SingleInvocationFilter.doFilter(SingleInvocationFilter.java:54)


The code on the JSP looks like (I created the WS client stubs using the Weblogic API's and ANT):




I then get the error mentioned above.

Can anyone please help me as to what might be causing this issue???
8 years ago

Rob Prime wrote:Although Ulf had requested for the full email addresses, this made them available for spammers who search the 'Net for email addresses. I've changed them slightly to make it at least a bit more difficult.

Now, where does the exception occur? At setting the form address at or at the to addresses at If it is the latter, you can find out exactly which one it is by using a simple print statement:
The last printed email address will be the one causing the problems.



Hi,

The error was occuring on at the to addresses. This is working now

I think passing the strict boolean value as false to the constructor (as below) has sorted this.


Thanks for the assistance.
8 years ago
I do think it is the "to" address because basically i'm sending the same address for the from and to, the other test data i'm passing from my Main method are as follows (main method snippet)



main method is calling this method

8 years ago
The address is passed as a String array as below:



8 years ago
Hi Guyz,

I'm having problems when trying to send an email through JavaMail API. an AddressException is thrown saying:

Illegal whitespace in address

My code looks like this:



Any assistance would be great.
8 years ago
Hi Yucca,

congrats -

may be you can elaborate more on your Preparation and the time it took to prepare e.t.c

Thanks.
congrats - good work
8 years ago
Congrats.

Short time - but great score . It think thats an achievement.

I'm planning to take up SCBCD next. i hope all goes well.
8 years ago