Harish Maridi

Ranch Hand
+ Follow
since May 20, 2008
Cows and Likes
Cows
Total received
0
In last 30 days
0
Total given
0
Likes
Total received
1
Received in last 30 days
0
Total given
0
Given in last 30 days
0
Forums and Threads
Scavenger Hunt
expand Ranch Hand Scavenger Hunt
expand Greenhorn Scavenger Hunt

Recent posts by Harish Maridi

Hi,

I am having the following issue, while I am trying to get TopicConnectionaFactory. I am not sure why my TopicConnectionFactory is getting as Reference. Any suggestion is welcome.

sampleorder.factory=cn=BrokerTopicConnectionFactory
Java Code that is causing the issue:


java.lang.ClassCastException: javax.naming.Reference cannot be cast to javax.jms.TopicConnectionFactory
at com.av.mobi.jca.esb.em.genesis.GenConnector$AsyncSampleOrderDelegate.publishRequest(GenConnector.java:915)
at com.av.mobi.jca.esb.em.genesis.GenConnector.doSampleOrder(GenConnector.java:734)

Difference I see when I print the Interface information if the factory lookup:

Working one is getting::
Object ref from factory lookup:
Interface: com.webmethods.jms.WmTopicConnectionFactory
Interface: javax.naming.Referenceable
Interface: java.io.Externalizable

Non Working one getting::
Object ref from factory lookup:
Interface: java.lang.Cloneable
Interface: java.io.Serializable

Dependencies added: (jboss-deployment-structure.xml)
<module name="com.av.json" export="true"/>
<module name="com.av.commons-httpclient" export="true"/>
<module name="com.av.axis2-adb" export="true"/>
<module name="com.av.geronimo-jms" export="true"/>
<module name="com.av.wmjmsclient" export="true"/>
<module name="sun.jdk" export="true"/>
<module name="com.av.AvMobileAxis2Services"/>
<module name="com.av.AvUtilities"/>

Thanks,
HM
7 years ago
Hi,

I tried to configure my data source in standalone.xml, I am getting the following issue in logs

JBAS014775: New missing/unsatisfied dependencies:
service jboss.jdbc-driver.ojdbc2 (missing) dependents: [service jboss.driver-demander.java:jboss/datasources/SalesPerformanceData, service jboss.data-source.java:jboss/datasources/SalesPerformanceData]

Configuration in standalone.xml::
<datasource jndi-name="java:jboss/datasources/SalesPerformanceData" pool-name="SalesPerformanceData" enabled="true" use-java-context="true">
<connection-url>jdbc:oracle:thin:@myserverIP:EP1</connection-url>
<driver>ojdbc2</driver>
<security>
<user-name>userName</user-name>
<password>passWord</password>
</security>
</datasource>
<drivers>
<driver name="ojdbc2" module="com.oracledb.ojdbc14">
<xa-datasource-class>oracle.jdbc.driver.OracleDriver</xa-datasource-class>
</driver>
</drivers>

module.xml of ojdbc14 is:
<module xmlns="urn:jboss:module:1.1" name="com.oracledb.ojdbc14">
<resources>
<resource-root path="ojdbc14.jar"/>
</resources>
<dependencies>
</dependencies>
</module>

I tried to find out dependencies of ojdbc14.jar, looks like it is not dependent on any other jars. Please let me know how to fix this issue or let me know if I missed anything.

Thanks,
HM
7 years ago
Moved to XML forum, posted here due to my overlook.

Thanks,
HM
7 years ago
Hi,

I have following xml that I am looking to convert it to JSON, I am using XML.java class to convert, method toJSONObject(xml), Posted code below. braces are missing from different places.
Please let me know if my xml format is bad or is there anything I am missing.

Output that I am getting:
"orgInfo":"genesisId":,"regionName":"SALES ADMIN REGION","areaName":"SALES ADMIN","branchNumber":"088","branchName":"AV/ELECTRO AIR","areaId":"96","partyId":"1646171","jobRole":,"regionId":"96","jobRoleAcronym":},"managerInfo":"contactInfo":"eMail":,"name":"middle":,"last":,"salutation":,"first":},
"addressList":"address":"streetAddress3":,"streetAddress2":,"streetAddress1":,"zip":,"state":,"city":,"country":},"addressType":"Business"},"fax":},"employeeId":"38075"},
"contactInfo":"eMail":"harish.maridi@av.com","name":"last":"Maridi","first":"Harish"},"addressList":"address":"streetAddress3":,"streetAddress2":,"streetAddress1":,"zip":,
"state":,"city":,"country":},"addressType":"Business"},"phoneList":"phoneType":"Work","number":,"extension":}},"employeeId":"10031"}

Desired output::
{"orgInfo":{"genesisId":{},"regionName":"SALES ADMIN REGION","areaName":"SALES ADMIN","branchNumber":"088","branchName":"AV/ELECTRO AIR","areaId":"96",
"partyId":"1646171","jobRole":{},"jobRoleAcronym":{},"regionId":"96"},"managerInfo":{"contactInfo":{"eMail":{},"name":{"middle":{},"last":{},"salutation":{},"first":{}},
"addressList":{"address":{"streetAddress3":{},"streetAddress2":{},"streetAddress1":{},"zip":{},"state":{},"country":{},"city":{}},"addressType":"Business"},"fax":{}},
"employeeId":"38075"},"contactInfo":{"eMail":"harish.maridi@av.com","name":{"last":"Maridi","first":"Harish"},"addressList":{"address":{"streetAddress3":{},"streetAddress2":{},
"streetAddress1":{},"zip":{},"state":{},"country":{},"city":{}},"addressType":"Business"},"phoneList":{"phoneType":"Work","number":{},"extension":{}}},"profile":"authenticated","employeeId":"10031"}

Source XML::
<?xml version="1.0" encoding="UTF-8"?>
<ns3:queryEmployee xmlns:ns3="http://www.av.com/qryemp">
<queryEmployeeRequest>
<employeeId>10031</employeeId>
<getCustomerListFlag>false</getCustomerListFlag>
<getSupplierListFlag>false</getSupplierListFlag>
<msgCorrelationId>001</msgCorrelationId>
<getManagerInfoFlag>false</getManagerInfoFlag>
<getReporteesFlag>false</getReporteesFlag>
</queryEmployeeRequest>
<queryEmployeeResponse>
<employeeId>10031</employeeId>
<managerInfo>
<employeeId>38075</employeeId>
<contactInfo>
<eMail/>
<fax/>
<name>
<salutation/>
<first/>
<last/>
<middle/>
</name>
<addressList>
<addressType>Business</addressType>
<address>
<country/>
<zip/>
<state/>
<city/>
<streetAddress3/>
<streetAddress2/>
<streetAddress1/>
</address>
</addressList>
</contactInfo>
</managerInfo>
<contactInfo>
<eMail>harish.maridi@av.com</eMail>
<name>
<first>Harish</first>
<last>Maridi</last>
</name>
<addressList>
<addressType>Business</addressType>
<address>
<country/>
<zip/>
<state/>
<city/>
<streetAddress3/>
<streetAddress2/>
<streetAddress1/>
</address>
</addressList>
<phoneList>
<phoneType>Work</phoneType>
<number/>
<extension/>
</phoneList>
</contactInfo>
<orgInfo>
<jobRole/>
<jobRoleAcronym/>
<genesisId/>
<partyId>1646171</partyId>
<regionId>96</regionId>
<regionName>SALES ADMIN REGION</regionName>
<areaId>96</areaId>
<areaName>SALES ADMIN</areaName>
<branchNumber>H88</branchNumber>
<branchName>AV/ELECTRO AIR</branchName>
</orgInfo>
</queryEmployeeResponse>
</ns3:queryEmployee>

Code of XML.java
7 years ago
Hi,

I am getting this issue while calling a service. server is JBoss 6.1 eap, Please let me know whats wrong. There are no white spaces in the URL. did I miss any configuration on server?

17:30:34,229 INFO [stdout] (http-/127.0.0.1:8080-1) Setting timeout for queryEmployee to 90 seconds...
17:30:34,229 ERROR [stderr] (http-/127.0.0.1:8080-1) org.apache.axis2.AxisFault: Transport out has not been set
17:30:34,230 ERROR [stderr] (http-/127.0.0.1:8080-1) at org.apache.axis2.engine.AxisEngine.send(AxisEngine.java:383)
17:30:34,230 ERROR [stderr] (http-/127.0.0.1:8080-1) at org.apache.axis2.description.OutInAxisOperationClient.send(OutInAxisOperation.java:374)
17:30:34,231 ERROR [stderr] (http-/127.0.0.1:8080-1) at org.apache.axis2.description.OutInAxisOperationClient.executeImpl(OutInAxisOperation.java:211)
17:30:34,231 ERROR [stderr] (http-/127.0.0.1:8080-1) at org.apache.axis2.client.OperationClient.execute(OperationClient.java:163)
17:30:34,232 ERROR [stderr] (http-/127.0.0.1:8080-1) at com.av.mobile.ws.axis2.adb.esb.employee.v1_0.AvQuestInterfaces_DataNotification_PublicServiceStub.queryEmployee(AvQuestInterfaces_DataNotification_PublicServiceStub.java:263)
17:30:34,232 ERROR [stderr] (http-/127.0.0.1:8080-1) at com.av.mobile.ws.axis2.adb.esb.employee.v1_0.AvQuestInterfaces_DataNotification_PublicServiceStub.getEmployeeXML(AvQuestInterfaces_DataNotification_PublicServiceStub.java:168)
17:30:34,233 ERROR [stderr] (http-/127.0.0.1:8080-1) at com.av.connector.security.ManagedConnectionFactoryImpl.getCredentials(ManagedConnectionFactoryImpl.java:191)
17:30:34,234 ERROR [stderr] (http-/127.0.0.1:8080-1) at com.av.connector.security.ManagedConnectionFactoryImpl.execute(ManagedConnectionFactoryImpl.java:123)

Thanks,
HM
7 years ago
Hi,

With your help, I managed to get rid of all deployment issues, Now I am in a phase of resolving the application issues. I posted the issue on JBoss Community Forums.
JBoss Forums

I made some more changes to achieve the module dependency to work, but no luck. I followed the following link to create a module.
Module creation Tutorial

Error I am seeing in the console is:
09:45:47,164 ERROR [org.apache.catalina.core.ContainerBase.[jboss.web].[default-host].[/avmobi].[MobiRouterServlet]] (http-/127.0.0.1:8080-2) JBWEB000236: Servlet.service() for servlet MobiRouterServlet threw exception: java.lang.ClassNotFoundException: com.av.mobile.ws.axis2.adb.esb.employee.v1_0.AvQuestInterfaces_DataNotification_PublicServiceStub from [Module "deployment.AvCredentialConnector.rar:main" from Service Module Loader]
at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:190) [jboss-modules.jar:1.2.0.CR1]
at org.jboss.modules.ConcurrentClassLoader.performLoadClassUnchecked(ConcurrentClassLoader.java:468) [jboss-modules.jar:1.2.0.CR1]
at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:456) [jboss-modules.jar:1.2.0.CR1]
at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:423) [jboss-modules.jar:1.2.0.CR1]
at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:398) [jboss-modules.jar:1.2.0.CR1]
at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:120) [jboss-modules.jar:1.2.0.CR1]
at com.av.connector.security.ManagedConnectionFactoryImpl.getCredentials(ManagedConnectionFactoryImpl.java:191)

After seeing this error and I followed below steps from the tutorial:
1. Created folder structure :: com/av/mobile/ws/axis2/adb/esb/employee/v1_0/main in JBOSS_HOME/modules folder
2. I placed jar required in the main folder
3. Created module.xml with following contents
<module xmlns="urn:jboss:module:1.1" name="com.av.mobile.ws.axis2.adb.esb.employee.v1_0">
<resources>
<resource-root path="AvMobileAxis2Services.jar"/>
</resources>
<dependencies>
</dependencies>
</module>
4. I created an entry in MANIFEST.MF with dependencies, Here is the contents of MANIFEST.MF of AvCredentialConnector.rar
Manifest-Version: 1.0
Ant-Version: Apache Ant 1.7.0
Created-By: 24.45-b08 (Oracle Corporation)
Dependencies: com.av.mobile.ws.axis2.adb.esb.employee.v1_0
5. Once I restart the server, I see AvMobileAxis2Services.jar.index file in the module main folder.

After doing above steps, I am still seeing the same error, is there anything that I am missing?

Thanks,
HM
7 years ago
Hi,

I am trying to configure ejb jndi configuration for jboss 6.1 eap. which configuration file that I need to use standalone.xml or persistence.xml ? (Please provide an example code block, if available)
Here is my old configurations for Jboss 4.1:

Jboss-web.xml

<jboss-web>
<ejb-ref>
<ejb-ref-name>ejb/ESBProxy</ejb-ref-name>
<jndi-name>AvESBProxyBean/local</jndi-name>
</ejb-ref>
</jboss-web>

Web.xml:

<ejb-ref>
<ejb-ref-name>ejb/ESBProxy</ejb-ref-name>
<ejb-ref-type>Session</ejb-ref-type>
<home>com.av.mobile.ejb3.AvESBProxy</home>
<remote>com.av.mobile.ejb3.AvESBProxyRemote</remote>
<mapped-name>MyProxy</mapped-name>
</ejb-ref>

Code block that referes:

(AvESBProxy) ctx.lookup("AvESBProxyBean/local");

AvESBProxy class code:

@Local
public interface AvESBProxy {
public String executeSimpleJsonService(String service, String endpoint,
String inXsl, String outXsl, String json) throws Exception;
public java.lang.String executeSimpleXmlService(String service,
String endpoint, String inXsl, String outXsl, String xml)
throws Exception;
}

Please let me know where do I need to do the ejb jndi configuration in Jboss eap 6.1

Thanks,
Mark
7 years ago
Hi,

I am trying to deploy a rar file to jboss/standalone/deployments folder. rar has derby, json1.0 jars. When there is no json1.0 jar is available then I saw ClassNotFound error with JSONException. After I included json1.0 jar, I started seeing java.lang.InstantiationException in server.log, There is not much explanation. Forums mentioning that this might be related to wrong jar versions. Please help me fix this issue.

This rar is associated with a jndi name binding. definded in standalone.xml. Please let me know if any more details needed.

16:40:05,430 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-16) MSC00001: Failed to start service jboss.ra.deployment."CommonAuditLogConnector.rar_1": org.jboss.msc.service.StartException in service jboss.ra.deployment."CommonAuditLogConnector.rar_1": org.jboss.msc.service.StartException in anonymous service: JBAS010446: Failed to start RA deployment [CommonAuditLogConnector]
at org.jboss.as.connector.services.resourceadapters.deployment.ResourceAdapterXmlDeploymentService.start(ResourceAdapterXmlDeploymentService.java:131)
at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.4.GA.jar:1.0.4.GA]
at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.4.GA.jar:1.0.4.GA]
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895) [rt.jar:1.6.0_45]
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918) [rt.jar:1.6.0_45]
at java.lang.Thread.run(Thread.java:662) [rt.jar:1.6.0_45]
Caused by: org.jboss.msc.service.StartException in anonymous service: JBAS010446: Failed to start RA deployment [CommonAuditLogConnector]
at org.jboss.as.connector.services.resourceadapters.deployment.ResourceAdapterXmlDeploymentService.start(ResourceAdapterXmlDeploymentService.java:115)
... 5 more
Caused by: org.jboss.jca.deployers.common.DeployException: JBAS010472: Deployment com.avnet.mobi.jca.logging.audit.CommonAuditLogConnector failed
at org.jboss.as.connector.services.resourceadapters.deployment.AbstractResourceAdapterDeploymentService$AbstractAS7RaDeployer.initAndInject(AbstractResourceAdapterDeploymentService.java:450)
at org.jboss.jca.deployers.common.AbstractResourceAdapterDeployer.createObjectsAndInjectValue(AbstractResourceAdapterDeployer.java:1364)
at org.jboss.as.connector.services.resourceadapters.deployment.ResourceAdapterXmlDeploymentService$AS7RaXmlDeployer.doDeploy(ResourceAdapterXmlDeploymentService.java:183)
at org.jboss.as.connector.services.resourceadapters.deployment.ResourceAdapterXmlDeploymentService.start(ResourceAdapterXmlDeploymentService.java:108)
... 5 more
Caused by: java.lang.InstantiationException: com.avnet.mobi.jca.logging.audit.CommonAuditLogConnector
at java.lang.Class.newInstance0(Class.java:342) [rt.jar:1.6.0_45]
at java.lang.Class.newInstance(Class.java:310) [rt.jar:1.6.0_45]
at org.jboss.as.connector.services.resourceadapters.deployment.AbstractResourceAdapterDeploymentService$AbstractAS7RaDeployer.initAndInject(AbstractResourceAdapterDeploymentService.java:416)
... 8 more

Thanks
7 years ago
Hi,

I am trying to deploy rar file to standalone/deployments folder which is configured as a resource adapter in standalone.xml. while depoying I am having some issues. Please let me know if I am doing anything wrong. I am also attaching rar file with this post.
ra.xml of rar has::
<managedconnectionfactory-class>com.avnet.mobi.jca.logging.audit.CommonAuditLogConnector</managedconnectionfactory-class> (thinking this is the source of the issue)
Standalone.xml config:
<subsystem xmlns="urn:jboss:domain:resource-adapters:1.1">
<resource-adapters>
<resource-adapter id="CommonAuditLogConnector.rar">
<archive>
CommonAuditLogConnector.rar
</archive>
<connection-definitions>
<connection-definition class-name="javax.resource.cci.ConnectionFactory" jndi-name="java:logging/common/AuditLog" enabled="true" pool-name="AuditLog"/>
</connection-definitions>
</resource-adapter>
</resource-adapters>
</subsystem>
Errors while deploying::
11:47:36,456 WARN [org.jboss.as.connector.deployers.RaXmlDeployer] (MSC service thread 1-12) IJ020004: Only one connection definition found with a mismatch in class-name: javax.resource.cci.ConnectionFactory
11:47:36,460 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-12) MSC00001: Failed to start service jboss.ra.deployment."CommonAuditLogConnector.rar_1": org.jboss.msc.service.StartException in service jboss.ra.deployment."CommonAuditLogConnector.rar_1": org.jboss.msc.service.StartException in anonymous service: JBAS010446: Failed to start RA deployment [CommonAuditLogConnector]
at org.jboss.as.connector.services.resourceadapters.deployment.ResourceAdapterXmlDeploymentService.start(ResourceAdapterXmlDeploymentService.java:131)
at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.4.GA.jar:1.0.4.GA]
at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.4.GA.jar:1.0.4.GA]
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895) [rt.jar:1.6.0_45]
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918) [rt.jar:1.6.0_45]
at java.lang.Thread.run(Thread.java:662) [rt.jar:1.6.0_45]
Caused by: org.jboss.msc.service.StartException in anonymous service: JBAS010446: Failed to start RA deployment [CommonAuditLogConnector]
at org.jboss.as.connector.services.resourceadapters.deployment.ResourceAdapterXmlDeploymentService.start(ResourceAdapterXmlDeploymentService.java:115)
... 5 more
Caused by: org.jboss.jca.deployers.common.DeployException: com.avnet.mobi.jca.logging.audit.CommonAuditLogConnector not a valid connection definition
at org.jboss.jca.deployers.common.AbstractResourceAdapterDeployer.findConnectionDefinitions(AbstractResourceAdapterDeployer.java:476)
at org.jboss.jca.deployers.common.AbstractResourceAdapterDeployer.createObjectsAndInjectValue(AbstractResourceAdapterDeployer.java:1310)
at org.jboss.as.connector.services.resourceadapters.deployment.ResourceAdapterXmlDeploymentService$AS7RaXmlDeployer.doDeploy(ResourceAdapterXmlDeploymentService.java:183)
at org.jboss.as.connector.services.resourceadapters.deployment.ResourceAdapterXmlDeploymentService.start(ResourceAdapterXmlDeploymentService.java:108)
... 5 more

Thanks,
Mark
7 years ago
Hi,

Can anyone let me know how JNDI binding should be done on Jboss 6.1 eap. Here is the JNDI name binding done in Jboss 4.1, in Jboss 4.1 I see no issues, in Jboss 6.1 I see lot of issues. Please let me know how to perform a JNDI name binding in jBoss EAP 6.1

CommonAuditLogConnector.rar is deployed to standalone/deployments

avmobi.war
web.xml
<filter>
<filter-name>StatisticsFilter</filter-name>
<filter-class>
com.avnet.mobi.server.filter.AvnetMobilityStatisticsFilter
</filter-class>
<init-param>
<param-name>LoggerJndiName</param-name>
<param-value>java:logging/common/AuditLog</param-value>
</init-param>
</filter>

I have this code block:
String jndi = arg0.getInitParameter("LoggerJndiName");
cf = (ConnectionFactory) ctx.lookup(jndi);

I have a CommonAuditLogConnector.rar file and CommonAuditLogConnector-ds.xml file contents are

<connection-factories>
<no-tx-connection-factory>
<jndi-name>logging/common/AuditLog</jndi-name>
<rar-name>CommonAuditLogConnector.rar</rar-name>
<connection-definition>javax.resource.cci.ConnectionFactory</connection-definition>
</no-tx-connection-factory>
</connection-factories>

If I am trying to deploy CommonAuditLogConnector-ds.xml then I see below error:: Is there any otherway to make JNDI name binding without using -ds.xml?

21,547 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-16) MSC00001: Failed to start service jboss.deployment.unit."CommonAuditLogConnector-ds.xml".PARSE: org.jboss.msc.service.StartException in service jboss.deployment.unit."CommonAuditLogConnector-ds.xml".PARSE: JBAS018733: Failed to process phase PARSE of deployment "CommonAuditLogConnector-ds.xml"

I am seeing the following error while deploying the jar::
Error Log:
12:47:01,631 INFO [com.avnet.mobi.server.filter.AvMobilityStatisticsFilter] (ServerService Thread Pool -- 58) Looking up logging connector at: java:logging/common/AuditLog
12:47:01,631 ERROR [com.avnet.mobi.server.filter.AvMobilityStatisticsFilter] (ServerService Thread Pool -- 58) Error obtaining logging connector 'java:logging/common/AuditLog': java:logging/common/AuditLog
12:47:01,632 ERROR [stderr] (ServerService Thread Pool -- 58) javax.naming.NameNotFoundException: java:logging/common/AuditLog

Thanks,
Mark
7 years ago
Hi,

I am trying to migrate my application from 4.1 to 6.1 eap, when I try to deploy my *-ds.xml file I am seeing below error. Please suggest what is wrong.
stanalone/deployments is where I am trying to deploy. Content of *-ds.xml is below. Please let me know is there any work around this issue. Seems that tags are not recognized by 6.1, Please let me know how to make them compatible with 6.1

<connection-factories>
<no-tx-connection-factory>
<jndi-name>logging/common/AuditLog</jndi-name>
<rar-name>CommonAuditLogConnector.rar</rar-name>
<connection-definition>javax.resource.cci.ConnectionFactory</connection-definition>
</no-tx-connection-factory>
</connection-factories>

21,547 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-16) MSC00001: Failed to start service jboss.deployment.unit."CommonAuditLogConnector-ds.xml".PARSE: org.jboss.msc.service.StartException in service jboss.deployment.unit."CommonAuditLogConnector-ds.xml".PARSE: JBAS018733: Failed to process phase PARSE of deployment "CommonAuditLogConnector-ds.xml"
at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:127) [jboss-as-server-7.2.0.Alpha1-redhat-4.jar:7.2.0.Alpha1-redhat-4]
at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.4.GA.jar:1.0.4.GA]
at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.4.GA.jar:1.0.4.GA]
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895) [rt.jar:1.6.0_45]
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918) [rt.jar:1.6.0_45]
at java.lang.Thread.run(Thread.java:662) [rt.jar:1.6.0_45]
Caused by: org.jboss.as.server.deployment.DeploymentUnitProcessingException: IJ010061: Unexpected element: connection-factories
at org.jboss.as.connector.deployers.ds.processors.DsXmlDeploymentParsingProcessor.deploy(DsXmlDeploymentParsingProcessor.java:92)
at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:120) [jboss-as-server-7.2.0.Alpha1-redhat-4.jar:7.2.0.Alpha1-redhat-4]
... 5 more
Caused by: org.jboss.jca.common.metadata.ParserException: IJ010061: Unexpected element: connection-factories
at org.jboss.jca.common.metadata.ds.v10.DsParser.parse(DsParser.java:128)
at org.jboss.jca.common.metadata.ds.v10.DsParser.parse(DsParser.java:87)
at org.jboss.as.connector.deployers.ds.processors.DsXmlDeploymentParsingProcessor.deploy(DsXmlDeploymentParsingProcessor.java:86)
... 6 more

Thanks,
Mark
7 years ago
Thanks Jaikiran for your reply.
rar file is deployed, but I am sure the JNDI binding is not done. Can you tell me how to do JNDI binding (configuration in standalone.xml) ?, Please give me some pointers on how to configure JNDI binding?
if I use *-ds.xml file I am getting ""PARSE exception, in the documentation it was mentioned that *-ds.xml configs are no longer supported. it is not clear how to configure this (This is the first time I am working with Jboss).
I will also try changing JNDI lookup name.

Once again thanks a lot for your time.

thanks,
Mark
7 years ago
Hi,

I am able to solve the first issue, now I am having new issue.
I included log4j, commons jars in lib folder, still the issue exists. Web.xml contains following code block, Please suggest what to do to get rid of this issue.

WEB.XML
<filter>
<filter-name>StatisticsFilter</filter-name>
<filter-class>
com.avnet.mobi.server.filter.AvMobilityStatisticsFilter
</filter-class>
<init-param>
<param-name>LoggerJndiName</param-name>
<param-value>java:logging/common/AuditLog</param-value>
</init-param>
</filter>

it was mentioned in the config file: CommonAuditLogConnector-ds.xml (-ds.xml s are no longer used in JBoss 6.1 EAP), so How do I make sure my war file gets reference of "CommonAuditLogConnector.rar" file, which is already deployed to standalone/deployments folder ?

<connection-factories>
<no-tx-connection-factory>
<jndi-name>logging/common/AuditLog</jndi-name>
<rar-name>CommonAuditLogConnector.rar</rar-name>
<connection-definition>javax.resource.cci.ConnectionFactory</connection-definition>
</no-tx-connection-factory>
</connection-factories>

Error Log:
12:47:01,631 INFO [com.avnet.mobi.server.filter.AvMobilityStatisticsFilter] (ServerService Thread Pool -- 58) Looking up logging connector at: java:logging/common/AuditLog
12:47:01,631 ERROR [com.avnet.mobi.server.filter.AvMobilityStatisticsFilter] (ServerService Thread Pool -- 58) Error obtaining logging connector 'java:logging/common/AuditLog': java:logging/common/AuditLog
12:47:01,632 ERROR [stderr] (ServerService Thread Pool -- 58) javax.naming.NameNotFoundException: java:logging/common/AuditLog
12:47:01,632 ERROR [stderr] (ServerService Thread Pool -- 58) at org.jboss.as.naming.InitialContext.findContext(InitialContext.java:198)
12:47:01,632 ERROR [stderr] (ServerService Thread Pool -- 58) at org.jboss.as.naming.InitialContext.lookup(InitialContext.java:118)
12:47:01,633 ERROR [stderr] (ServerService Thread Pool -- 58) at org.jboss.as.naming.NamingContext.lookup(NamingContext.java:183)
12:47:01,633 ERROR [stderr] (ServerService Thread Pool -- 58) at org.jboss.as.naming.NamingContext.lookup(NamingContext.java:179)
12:47:01,633 ERROR [stderr] (ServerService Thread Pool -- 58) at javax.naming.InitialContext.lookup(InitialContext.java:392)
12:47:01,634 ERROR [stderr] (ServerService Thread Pool -- 58) at com.avnet.mobi.server.filter.AvnetMobilityStatisticsFilter.init(AvMobilityStatisticsFilter.java:608)
12:47:01,634 ERROR [stderr] (ServerService Thread Pool -- 58) at org.apache.catalina.core.ApplicationFilterConfig.getFilter(ApplicationFilterConfig.java:416)
12:47:01,637 ERROR [stderr] (ServerService Thread Pool -- 58) at org.apache.catalina.core.StandardContext.filterStart(StandardContext.java:3225)
12:47:01,637 ERROR [stderr] (ServerService Thread Pool -- 58) at org.apache.catalina.core.StandardContext.start(StandardContext.java:3791)
12:47:01,637 ERROR [stderr] (ServerService Thread Pool -- 58) at org.jboss.as.web.deployment.WebDeploymentService.doStart(WebDeploymentService.java:156)
12:47:01,638 ERROR [stderr] (ServerService Thread Pool -- 58) at org.jboss.as.web.deployment.WebDeploymentService.access$000(WebDeploymentService.java:60)
12:47:01,640 ERROR [stderr] (ServerService Thread Pool -- 58) at org.jboss.as.web.deployment.WebDeploymentService$1.run(WebDeploymentService.java:93)
12:47:01,640 ERROR [stderr] (ServerService Thread Pool -- 58) at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:439)
12:47:01,640 ERROR [stderr] (ServerService Thread Pool -- 58) at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
12:47:01,641 ERROR [stderr] (ServerService Thread Pool -- 58) at java.util.concurrent.FutureTask.run(FutureTask.java:138)
12:47:01,642 ERROR [stderr] (ServerService Thread Pool -- 58) at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895)
12:47:01,642 ERROR [stderr] (ServerService Thread Pool -- 58) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918)
12:47:01,643 ERROR [stderr] (ServerService Thread Pool -- 58) at java.lang.Thread.run(Thread.java:662)
12:47:01,643 ERROR [stderr] (ServerService Thread Pool -- 58) at org.jboss.threads.JBossThread.run(JBossThread.java:122)
12:47:01,655 ERROR [org.apache.catalina.core.ContainerBase.[jboss.web].[default-host].[/avmobi]] (ServerService Thread Pool -- 58) JBWEB000284: Exception starting filter StatisticsFilter: javax.servlet.ServletException: Error obtaining logging connector: java:logging/common/AuditLog
at com.avnet.mobi.server.filter.AvnetMobilityStatisticsFilter.init(AvMobilityStatisticsFilter.java:619) [avmobi.jar:]
at org.apache.catalina.core.ApplicationFilterConfig.getFilter(ApplicationFilterConfig.java:416) [jbossweb-7.2.0.Final.jar:7.2.0.Final]
at org.apache.catalina.core.StandardContext.filterStart(StandardContext.java:3225) [jbossweb-7.2.0.Final.jar:7.2.0.Final]
at org.apache.catalina.core.StandardContext.start(StandardContext.java:3791) [jbossweb-7.2.0.Final.jar:7.2.0.Final]
at org.jboss.as.web.deployment.WebDeploymentService.doStart(WebDeploymentService.java:156) [jboss-as-web-7.2.0.Alpha1-redhat-4.jar:7.2.0.Alpha1-redhat-4]
at org.jboss.as.web.deployment.WebDeploymentService.access$000(WebDeploymentService.java:60) [jboss-as-web-7.2.0.Alpha1-redhat-4.jar:7.2.0.Alpha1-redhat-4]
at org.jboss.as.web.deployment.WebDeploymentService$1.run(WebDeploymentService.java:93) [jboss-as-web-7.2.0.Alpha1-redhat-4.jar:7.2.0.Alpha1-redhat-4]
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:439) [rt.jar:1.6.0_45]
at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303) [rt.jar:1.6.0_45]
at java.util.concurrent.FutureTask.run(FutureTask.java:138) [rt.jar:1.6.0_45]
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895) [rt.jar:1.6.0_45]
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918) [rt.jar:1.6.0_45]
at java.lang.Thread.run(Thread.java:662) [rt.jar:1.6.0_45]
at org.jboss.threads.JBossThread.run(JBossThread.java:122)

12:47:01,659 INFO [com.avnet.mobi.server.filter.LdapAuthenticationWithSimpleJsonFilter] (ServerService Thread Pool -- 58) com.avnet.mobi.server.filter.LdapAuthenticationWithSimpleJsonFilter successfully initialized - watching for parameter: auth
12:47:01,660 ERROR [org.apache.catalina.core] (ServerService Thread Pool -- 58) JBWEB001103: Error detected during context /avmobi start, will stop it
12:47:01,668 ERROR [org.jboss.msc.service.fail] (ServerService Thread Pool -- 58) MSC00001: Failed to start service jboss.web.deployment.default-host./avmobi: org.jboss.msc.service.StartException in service jboss.web.deployment.default-host./avmobi: org.jboss.msc.service.StartException in anonymous service: JBAS018040: Failed to start context
at org.jboss.as.web.deployment.WebDeploymentService$1.run(WebDeploymentService.java:96)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:439) [rt.jar:1.6.0_45]
at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303) [rt.jar:1.6.0_45]
at java.util.concurrent.FutureTask.run(FutureTask.java:138) [rt.jar:1.6.0_45]
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895) [rt.jar:1.6.0_45]
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918) [rt.jar:1.6.0_45]
at java.lang.Thread.run(Thread.java:662) [rt.jar:1.6.0_45]
at org.jboss.threads.JBossThread.run(JBossThread.java:122)
Caused by: org.jboss.msc.service.StartException in anonymous service: JBAS018040: Failed to start context
at org.jboss.as.web.deployment.WebDeploymentService.doStart(WebDeploymentService.java:161)
at org.jboss.as.web.deployment.WebDeploymentService.access$000(WebDeploymentService.java:60)
at org.jboss.as.web.deployment.WebDeploymentService$1.run(WebDeploymentService.java:93)
... 7 more

Appreciate any suggestions. Thanks,
Mark
7 years ago
Hi Ranchers,

I am trying to migrate the projects from JBoss 4.1 to 6.1, and I have never worked on JBoss. I had some issues with dependencies to resolve I removed content from jboss-web.xml, and included jars in WEB-INF/lib. Dependency issues are gone but now I am seeing the following issues: Please let me know how to fix this STRUCTURE issue, do I need to change the structure of my war file?

09:33:18,565 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-4) MSC00001: Failed to start service jboss.deployment.unit."avmobi.war".STRUCTURE: org.jboss.msc.service.StartException in service jboss.deployment.unit."avmobi.war".STRUCTURE: JBAS018733: Failed to process phase STRUCTURE of deployment "avmobi.war"
at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:127) [jboss-as-server-7.2.0.Alpha1-redhat-4.jar:7.2.0.Alpha1-redhat-4]
at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.4.GA.jar:1.0.4.GA]
at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.4.GA.jar:1.0.4.GA]
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895) [rt.jar:1.6.0_45]
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918) [rt.jar:1.6.0_45]
at java.lang.Thread.run(Thread.java:662) [rt.jar:1.6.0_45]
Caused by: org.jboss.as.server.deployment.DeploymentUnitProcessingException: JBAS018740: Failed to mount deployment content
at org.jboss.as.server.deployment.module.DeploymentRootMountProcessor.deploy(DeploymentRootMountProcessor.java:92) [jboss-as-server-7.2.0.Alpha1-redhat-4.jar:7.2.0.Alpha1-redhat-4]
at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:120) [jboss-as-server-7.2.0.Alpha1-redhat-4.jar:7.2.0.Alpha1-redhat-4]
... 5 more
Caused by: java.util.zip.ZipException: error in opening zip file
at java.util.zip.ZipFile.open(Native Method) [rt.jar:1.6.0_45]
at java.util.zip.ZipFile.<init>(ZipFile.java:127) [rt.jar:1.6.0_45]
at java.util.zip.ZipFile.<init>(ZipFile.java:143) [rt.jar:1.6.0_45]
at org.jboss.vfs.VFSUtils.unzip(VFSUtils.java:845)
at org.jboss.vfs.VFS.mountZipExpanded(VFS.java:536)
at org.jboss.vfs.VFS.mountZipExpanded(VFS.java:567)
at org.jboss.as.server.deployment.DeploymentMountProvider$Factory$ServerDeploymentRepositoryImpl.mountDeploymentContent(DeploymentMountProvider.java:97) [jboss-as-server-7.2.0.Alpha1-redhat-4.jar:7.2.0.Alpha1-redhat-4]
at org.jboss.as.server.deployment.module.DeploymentRootMountProcessor.deploy(DeploymentRootMountProcessor.java:88) [jboss-as-server-7.2.0.Alpha1-redhat-4.jar:7.2.0.Alpha1-redhat-4]
... 6 more

Thanks,
Mark
7 years ago