nidhivel raja

Ranch Hand
+ Follow
since Jun 26, 2008
Cows and Likes
Cows
Total received
0
In last 30 days
0
Total given
0
Likes
Total received
0
Received in last 30 days
0
Total given
0
Given in last 30 days
0
Forums and Threads
Scavenger Hunt
expand Ranch Hand Scavenger Hunt
expand Greenhorn Scavenger Hunt

Recent posts by nidhivel raja

Hi all,
I am getting Connection reset error thrown from Axis 1.4 webservice deployed in weblogic 10.3 server,when making consecutive calls after first call to webservice

Detailed decription

I have a web application deployed on one Weblogic 10.3 server, it is trying to access an axis 1.4 webservice deployed on another weblogic10.3 server.It accesses the webservice with the help of client stubs generated by WSDL2Java class.The first time when the stub calls the service using invoke() method it is able to hit the webservice.But the when the same stub calls the webservice for second time it is giving me the following COnnection reset error.Can anybody please tell me whats the solution to this error or any place where i am going wrong

Following is The exception


Following is the stub code that i am using ,the error is being thrown at the following line
java.lang.Object _resp = _call.invoke(new java.lang.Object[] {arg1, arg2, arg3});




Please do provide your valuable solutions.thank you in advance




5 years ago
Hi Bear,

Thanks for your reply.i did as you advised i restarted my server as well as PC,I even cleared my cache in the browser.Now i am able to get the desired output as 7!!! :D

I think the earlier problem occured because of cache pages in the browser,anyways thankx a lot Bear:D
8 years ago
JSP
Hi all
I am reading Head First Servlets 2nd edition,In the JSP elements topic(chapter 7) there's a table that displays the status of EL evaluation(page 327).From the details given i understand,that if both the DD configuration and Page directive are unspeciifed for EL evaluation then El expresions will be evaluated.

I created a simple web application from the same book, where i have specified the version of web.xml as 2.4(My Tomcat version is 5.5) but still the El is not being evaluated
Following is my web.xml




My form.html
<html>
<h1 align="center">Beer Selection Page</h1>
<form method="POST" action="SelectBeer.do">
Select beer characterstics


Color:
<select name="color" size="1">
<option value="light">light</option>
<option value="amber">amber</option>
<option value="brown">brown</option>
<option value="dark">dark</option>
</select>



<center>
<input type="SUBMIT">
</center>
</form></body>
</html>



My Servlet BeerSelect.java



Finally my result.JSP

<html>
<h1 align="center">Result Page</h1>


Color of life as follows:
${requestScope.coloroflife} is yours!!!




<center>
<input type="SUBMIT">
</center>
</form></body>
</html>



When the user selects the beer choice and submits the form ,the selected result is forwarded to the result jsp with the attribute in requestScope.
Inspite of version of the DD 2.4 my EL is not being evaluated,I dont know the reason for this, Given the condition that both the page directive and DD configuration are unspecified,as per the book the El should be evaluated.Can anyone please help me in this issue.? Thank you in advance

ps:I browsed through other topics in the same forum regarding this problem ,and found that such problems arise due to version mismatches,but in my case i think i have already set my version as 2.4 .

8 years ago
JSP
Hi Mr.Prasad Krishnegowda& Mr.Michael Angstadt ,

The Problem is solved ,I tried replacing the existing anchor tags with the following attributes,

and it works !!!

Thanks a lot for spending your time in helping me to solve my problem
10 years ago
Hi,
I checked the server Tomcat Server 6.0 Log,its not showing any errors,but in the server window ,i got the following exception before startup



Any idea what is the reason for this error?
10 years ago
Hi ,
Sure,
I viewed the source code of the Welcome.jsp,it is the same as another webpage in a different application with the name Welcome.jsp,

The following is the code of the Welcome.jsp


As an alternative, I have deleted the other applications and right now i have created a very simple web app with just three jsp
pages

1)index.jsp
2)WrongUser.jsp
3)Home.jsp
4)LoginServletThree

index.jsp




WrongUser.jsp



Home.jsp




LoginServletThree





The above servlet works fine when i run the webapp ,the Welcome page didnot appear this time(THANKS A LOT for your suggestions ) ,but when i the click the login page link in Home page and the Wronguser page i get a blank page instead of the index page(but the URL is /index.jsp) ......can you please give me a solution for this?
10 years ago
Thank you , for the suggestions Mr.Michael Angstadt

It seems like older versions of your files exist in your deployment environment. Try doing a clean build and then re-deploying your application.




I did as you said but i am facing the same problem.I even created a new web application but the problem with the welcome page and the text box exists ,Is there any other solution for this problem:(


10 years ago
sure,

I have attached directory structure screen shot with this reply,please do refer the attachment and give me your suggestions.
10 years ago
Hi,
I tried as you said but after removing the '/' when i click the login page link in the InvalidUserPage

i am getting the 404 error com/index.jsp is not available
10 years ago
If I click the link in the InvalidUserPage ,the resulting page has the URL index.jsp and the password textbox has now become an ordinary textbox(the password i enter is now visible).
even if i enter an invalid userid password,it takes me to another page with the URL Welcome.jsp .

10 years ago
Thank you for the reply Mr.Prasad Krishnegowda,

Sorry for the inconvenience,i didn't take notice of that part , but my jsp already has a href parameter in the anchor tag , when i paste my code here in javaranch the href attribute is removed ,i dont know the reason

The tag in my InvalidUser.jsp has href attribute as

The First
tag in my FirstLinkPage has href attribute as

The Second
tag in my FirstLinkPage has href attribute as

The Third
tag in my FirstLinkPage has href attribute as
10 years ago
Hi all
I am developing a web application that manages the data of employees
The following are the jsp files that I am using

Index.jsp(login details )



The Servlet for the above JSP LoginServlet




The above code is working without any errors ,On successful login it takes me to the FirstLinkPage and on invalid login it takes me to the InvalidUserPage.


FirstLinkPage.jsp



InvalidUserPage.jsp




Other jsps that I am using


CreateEmployeePage.jsp



ModifyEmployeePage.jsp



My web.xml is



The Problem

1)The problem that I face here is when I click the link on highlighted link in InvalidUserPage ,I get a page called Welcome.jsp with the two text boxes namely username and password .The password text box has its type as Text and not as password.
2)I don’t know how I got this page

Because I have created only the following JSPs and NOT a JSP called Welcome.jsp
CreateEmployeePage.jsp
Index.jsp
ModifyEmployeePage.jsp
FirstLinkPage.jsp
InvalidUserPage.jsp
3) Whenever I get back to the index jsp by clicking the link on FirstLinkPage jsp, the password text box type is changed to text(making the password visible) .when I give the correct login details after this it goes to Welcome.jsp
Can anyone please help me find a solution to this problem ,Thank you in advance




10 years ago
Hi all ,
Can anyone please tell me what is the difference between Casting and Conversion in Java?Thank you in advance
11 years ago
Thank you Mr.Sangram Mhatre, Mr.Vijay Jeyam and Mr.Bear Bibeault my doubt is cleared now
11 years ago

Originally posted by nidhivel raja:
Yes
Interface has is a group of method definitions .



Sorry for the mistake
Interface is a group of method definitions
11 years ago