salvin francis

+ Follow
since Jan 12, 2009
salvin likes ...
Eclipse IDE Google Web Toolkit Java
Cows and Likes
Total received
In last 30 days
Total given
Total received
Received in last 30 days
Total given
Given in last 30 days
Forums and Threads
Scavenger Hunt
(keep public parts private until JForum day)
expand Rancher Scavenger Hunt
expand Ranch Hand Scavenger Hunt
expand Greenhorn Scavenger Hunt
Moderation Tools

Recent posts by salvin francis

Campbell Ritchie wrote:I know there are party tricks like this:-

Adding my party trick:
1 week ago
The above answer should take 32439058308781800000000000000 centuries  to crack as per

However, the issue is that if a site stores such answers in clear text format, and a hacker gets access to one of them... 
But, the most certain thing is that when it comes to passwords/pass phrases, nonsense makes more sense than randomness. It could be a silly rhyme or complete rubbish sentence, but, it will be more secure than a shorter mixed character password.
2 weeks ago

Tim Moores wrote:How would you remember on which web site you used which nonsense answer to which question?

its simple, slight variations ....

No coderanch!! I won't give you my mommi's name?!!

2 weeks ago
Rather than adding a question, my suggestion would be to add totally nonsensical answers to such questions.

I heard that long phrases like
will take 285 nonillion years to crack

2 weeks ago

Knute Snortum wrote:There are other ways to do this, too.

If you are using java8, you can do something like:
2 weeks ago
Here's a code with comments to help you out:


PS: I would love to see you write OPs code and not everything in Main the way I did, I just wanted to write a short code to show you the concepts.
2 weeks ago

Pani Voskou wrote:...
The varargs parameter in  the main() method is incorrect.

Variable arguments in main work perfectly fine since Java 1.5 (I think).
4 weeks ago

femi Joseph wrote:
can someone please tell me if anything is wrong with this code ?
According to what I have read, final variable can only be initialized once and since the default value for class or static  variable is 0. this should compile and print out zero.

No, A final variable has to be initialized once before it can be used. It will not be set to "0" as you expected.

Now, since you have asked if anything is wrong with that code, here are a few points from my end:
  • "switchDemo" is a bad name for a class. It does not follow the naming convention as well as I don't see any 'switches' in the code
  • "me" is a bad name for an int variable, it does not describe what it does
  • Your code indentations are not correct


    4 weeks ago
    Hi Jason,
    Welcome to code ranch. I hope you have a pleasant experience learning java here. Since coderanch is a volunteer driven community, I cannot guarantee there would be an immediate response for all of your queries. If you show adequate effort in your question, I am sure you would get a very fast response.
    1 month ago
    Congratulations Jeanne. That's really awesome     
    1 month ago
    and  ... Welcome to code ranch !
    1 month ago
    Did you try it ?
    Does it throw any error ?
    Whats the source of the question ?
    1 month ago