Kieth Lyman

Greenhorn
+ Follow
since Feb 11, 2009
Cows and Likes
Cows
Total received
0
In last 30 days
0
Total given
0
Likes
Total received
0
Received in last 30 days
0
Total given
0
Given in last 30 days
0
Forums and Threads
Scavenger Hunt
expand Ranch Hand Scavenger Hunt
expand Greenhorn Scavenger Hunt

Recent posts by Kieth Lyman

Thanks for the reply Paul.  When I added:



I still get all the rows:
Thanks Rob.  I simply removed the ' @ConstructorResult(targetClass = com.xgenomics.salesperformance.dto.WorkEffectAverage.class,' line and that seems to have fixed it.
The Query:


The RESULT: (For example, I only want the max(date) record of 'Scott Byerly' '3')


Changing to this seems to have fixed it:

       
6 months ago
DTO:
     


DAO:
         
6 months ago
My WorkEffectAverage DTO:


My Mapping:
   
Also...this is a simple jsp/servlet/annotation application with Java7 running on Tomcat7
6 months ago
Here are the response headers:
HTTP/1.1 200 OK
Server: Apache-Coyote/1.1
Content-Type: text/html;charset=UTF-8
Content-Length: 0
Date: Sun, 17 Feb 2019 08:29:22 GMT
6 months ago
Yes, I do have another app running on 8080.
This is from the localhost_access_log:
0:0:0:0:0:0:0:1 - - [17/Feb/2019:03:17:46 -0500] "GET /10xsalesperf/ HTTP/1.1" 200 1345
0:0:0:0:0:0:0:1 - - [17/Feb/2019:03:17:46 -0500] "GET /10xsalesperf/css/bootstrap.min.css HTTP/1.1" 200 24576
0:0:0:0:0:0:0:1 - - [17/Feb/2019:03:17:46 -0500] "GET /10xsalesperf/css/misc.css HTTP/1.1" 200 1971
0:0:0:0:0:0:0:1 - - [17/Feb/2019:03:17:46 -0500] "GET /favicon.ico HTTP/1.1" 404 973
0:0:0:0:0:0:0:1 - - [17/Feb/2019:03:17:50 -0500] "POST /10xsalesperf/GetLoginServlet HTTP/1.1" 200 -

Thanks for any thoughts you might have on this...I'm really pulling my hair out on this one.
6 months ago
Thank you for the reply.  I am getting a blank screen when the servlet calls the jsp page under /WEB-INF/
6 months ago
Displaying/Forwarding to a jsp page from my servlet like this works fine:

  RequestDispatcher dispatcher = getServletContext().getRequestDispatcher("/test.jsp");
        dispatcher.forward(request, response);
}


Displaying/Forwarding to a jsp page from my servlet like this DOES NOT WORK, with no errors or info:
    RequestDispatcher dispatcher = getServletContext().getRequestDispatcher("/WEB-INF/test.jsp");
        dispatcher.forward(request, response);
}


Why can't tomcat7 'access' this page from the server side?
TIA!
6 months ago
Bear, did you mean 'context' is not shared between apps.
Session should not be a problem as it is based on the session id of the client which is passed in a cookie in the request.
8 years ago
response.sendRedirect created a new session on the second webapp from the first servlet...that did work. This is different than the 'submit'.
8 years ago
Would it matter if this first application 'a' does a 'response.sendRedirect' vs setting the action of a form and submitting that form
'
8 years ago
Hi Pravin,

First Servlet:
HttpSession session = request.getSession( true);
session.setAttribute("x", request.getParameter("x"));

Render jsp page:
...servletcontext.getRequestDispatcher(page.jsp.forward(req,res);

JSP:
<a href="/SetServlet?a=1&b=2"

SetServlet:
HttpSession session = request.getSession(true);
session.getAttribute("x") - THIS IS NULL BECAUSE IT'S A DIFF SESSION (VERIFIED BY DISPLAYING SESSIONID)
8 years ago