This week's book giveaway is in the Cloud/Virtualization forum.
We're giving away four copies of Mastering Corda: Blockchain for Java Developers and have Jamiel Sheikh on-line!
See this thread for details.
Win a copy of Mastering Corda: Blockchain for Java Developers this week in the Cloud/Virtualization forum!

Robinson Francis

Greenhorn
+ Follow
since Aug 16, 2010
Cows and Likes
Cows
Total received
0
In last 30 days
0
Total given
0
Likes
Total received
0
Received in last 30 days
0
Total given
1
Given in last 30 days
0
Forums and Threads
Scavenger Hunt
expand Ranch Hand Scavenger Hunt
expand Greenhorn Scavenger Hunt

Recent posts by Robinson Francis

Hi,
After importing my project into my IDE, Spring Tool Suite Version: 4.8.1.RELEASE, there is an error in the pom.xml file, the error message is as follows:
Plugin execution not covered by lifecycle configuration: org.apache.maven.plugins:maven-clean-plugin:3.1.0:clean (execution:
auto-clean, phase: initialize)

These are the content of my pom.xml:


I have tried other solutions offered but they don't seem to solve the other problems. Please let me know if you need more information. Thank you.
2 weeks ago
I have done a @OneToMany mapping and @ManyToOne mapping for these entities:


Resource.java





This is my repositories:





And this is the code in the service the that is calling this:



When my question is when I step through the codes using the debugger all the values are null, the H2 db has been loaded with data and  I can query it out using the console.
But Why are all the values of the properties of the returned object being set to null? The query returns results, the debug view even shows that the result_3 size is 1, but yet all the fields are empty. Can someone please help? Thank you in advance.
1 month ago
Thanks I removed the context-path from the url in Postman and it worked, thanks.
1 month ago
Dear all,
I have an Controller Class with the following annotations


I have taken the contents of @RequestMapping("projects/v1") and @GetMapping("/resources") to construct the url and entered it in Postman
http://localhost:8084/resource-service/projects/v1/resources

In response I have gotten is this
{
   "timestamp": 1607569944112,
   "status": 404,
   "error": "Not Found",
   "message": "No message available",
   "path": "/resource-service/projects/v1/resources"
}
These are the entries in the Spring Boot Terminal in INTELLIj IDE after firing the request

2020-12-10 11:07:13.708  INFO 5784 --- [nio-8084-exec-1] o.a.c.c.C.[Tomcat].[localhost].[/]       : Initializing Spring DispatcherServlet 'dispatcherServlet'
2020-12-10 11:07:13.709  INFO 5784 --- [nio-8084-exec-1] o.s.web.servlet.DispatcherServlet        : Initializing Servlet 'dispatcherServlet'
2020-12-10 11:07:13.734  INFO 5784 --- [nio-8084-exec-1] o.s.web.servlet.DispatcherServlet        : Completed initialization in 25 ms
2020-12-10 11:09:04.872  WARN 5784 --- [nio-8084-exec-3] o.s.web.servlet.PageNotFound             : No mapping for GET /resource-service/resources
2020-12-10 11:12:24.108  WARN 5784 --- [io-8084-exec-10] o.s.web.servlet.PageNotFound             : No mapping for GET /resource-service/projects/v1/resources

Can someone tell me what went wrong? Is there some configurations I need to do in application.yml or something?
1 month ago
Yes you are correct.
It worked after I followed your advise.
3 years ago
TO John Hoe,
THis is what is being displayed:

Internal loopSiebelAssetId:   1-7O0X33G BrmNodeLocationPoid: :0.0.0.1 /purchased_discount 118096179598 0
Internal loopSiebelAssetId:   1-7O0X33G BrmNodeLocationPoid: :0.0.0.1 /purchased_discount 118096179598 0
Internal loopSiebelAssetId:   1-7O0X33G BrmNodeLocationPoid: :0.0.0.1 /purchased_discount 118096179598 0
Internal loopSiebelAssetId:   1-7O0X33G BrmNodeLocationPoid: :0.0.0.1 /purchased_discount 118096179598 0
Internal loopSiebelAssetId:   1-7O0X33G BrmNodeLocationPoid: :0.0.0.1 /purchased_discount 118096179598 0
Internal loopSiebelAssetId:   1-7O0X33G BrmNodeLocationPoid: :0.0.0.1 /purchased_discount 118096179598 0

Thanks.
3 years ago
Dear All,
Kindly assist in this problem.
I am tryng to query from the db and save each ResulSet object into a List. However after each time the I add my my POJO object that holds values of the ResultSet it, it populates the whole list with the same values of the very last ResultSet value. All the previous ones are gone!
Below is the Code:

By calling obrmEAIXRefProductDOListTmp.add(xrefProductDO);, I thought I would add a new item to an existing list with all the previously added items being intact. But to my surprise, it created duplicates of the very last item and entered them into each row in the list!

Below is the result after exectuting System.out.println("Actual ArrayList:"+obrmEAIXRefProductDOListTmp);


SiebelAssetId:   1-7O0X33G BrmNodeLocationPoid: :0.0.0.1 /purchased_discount 118096179595 0
Actual ArrayList:[1-7O0X33G|1-7O0X331|SLPP|0.0.0.1 /discount 51751|0.0.0.1 /purchased_discount 118096179595 0]
SiebelAssetId:   1-7O0X33G BrmNodeLocationPoid: :0.0.0.1 /purchased_discount 118096179597 0
Actual ArrayList:[1-7O0X33G|1-7O0X331|SLPP|0.0.0.1 /discount 50791|0.0.0.1 /purchased_discount 118096179597 0, 1-7O0X33G|1-7O0X331|SLPP|0.0.0.1 /discount 50791|0.0.0.1 /purchased_discount 118096179597 0]
SiebelAssetId:   1-7O0X33G BrmNodeLocationPoid: :0.0.0.1 /purchased_product 118096179577 0
Actual ArrayList:[1-7O0X33G|1-7O0X331|SLPP|0.0.0.1 /product 50503|0.0.0.1 /purchased_product 118096179577 0, 1-7O0X33G|1-7O0X331|SLPP|0.0.0.1 /product 50503|0.0.0.1 /purchased_product 118096179577 0, 1-7O0X33G|1-7O0X331|SLPP|0.0.0.1 /product 50503|0.0.0.1 /purchased_product 118096179577 0]
SiebelAssetId:   1-7O0X33G BrmNodeLocationPoid: :0.0.0.1 /purchased_product 118096179578 0
Actual ArrayList:[1-7O0X33G|1-7O0X331|SLPP|0.0.0.1 /product 50605|0.0.0.1 /purchased_product 118096179578 0, 1-7O0X33G|1-7O0X331|SLPP|0.0.0.1 /product 50605|0.0.0.1 /purchased_product 118096179578 0, 1-7O0X33G|1-7O0X331|SLPP|0.0.0.1 /product 50605|0.0.0.1 /purchased_product 118096179578 0, 1-7O0X33G|1-7O0X331|SLPP|0.0.0.1 /product 50605|0.0.0.1 /purchased_product 118096179578 0]
SiebelAssetId:   1-7O0X33G BrmNodeLocationPoid: :0.0.0.1 /purchased_discount 118096179596 0
Actual ArrayList:[1-7O0X33G|1-7O0X331|SLPP|0.0.0.1 /discount 52839|0.0.0.1 /purchased_discount 118096179596 0, 1-7O0X33G|1-7O0X331|SLPP|0.0.0.1 /discount 52839|0.0.0.1 /purchased_discount 118096179596 0, 1-7O0X33G|1-7O0X331|SLPP|0.0.0.1 /discount 52839|0.0.0.1 /purchased_discount 118096179596 0, 1-7O0X33G|1-7O0X331|SLPP|0.0.0.1 /discount 52839|0.0.0.1 /purchased_discount 118096179596 0, 1-7O0X33G|1-7O0X331|SLPP|0.0.0.1 /discount 52839|0.0.0.1 /purchased_discount 118096179596 0]
SiebelAssetId:   1-7O0X33G BrmNodeLocationPoid: :0.0.0.1 /purchased_discount 118096179598 0
Actual ArrayList:[1-7O0X33G|1-7O0X331|SLPP|0.0.0.1 /discount 51815|0.0.0.1 /purchased_discount 118096179598 0, 1-7O0X33G|1-7O0X331|SLPP|0.0.0.1 /discount 51815|0.0.0.1 /purchased_discount 118096179598 0, 1-7O0X33G|1-7O0X331|SLPP|0.0.0.1 /discount 51815|0.0.0.1 /purchased_discount 118096179598 0, 1-7O0X33G|1-7O0X331|SLPP|0.0.0.1 /discount 51815|0.0.0.1 /purchased_discount 118096179598 0, 1-7O0X33G|1-7O0X331|SLPP|0.0.0.1 /discount 51815|0.0.0.1 /purchased_discount 118096179598 0, 1-7O0X33G|1-7O0X331|SLPP|0.0.0.1 /discount 51815|0.0.0.1 /purchased_discount 118096179598 0]



I know it maybe trivial to some out there, but this code is part of bigger effort, but I am stuck ni this part. I would extremely grateful to everyone of you if you could assist me.
THanks.
3 years ago
I have some problems when trying to POST Http Requests to Application Hosted on WeblogiC 10gR3 server. My application is a Spring Framework based Middleware Java application. I have already deployed the EAR on my local machine(the Weblogic server is run on my local as well). I am trying to use JMeter to POST http requests to it but whenever I run the test plan, I get the following error:



The JMeter test is also run on my own computer.

Below are the parameters I have filled in the Http Request element configuration:

Server Name or IP: 127.0.0.1 Port Number: 7001 Protocol : HTTP Method : POST Path : /iCareEAI_Sync_App_war/httpMessageReceiver.do

And I have chosen to populate the Post Body tab with the XML that intend to POST.



I hope this could help. Please feel free to ask for more information. I am not sure as to what more to add. I was hoping that through an interactive session I will be able to arrive at a solution that is relevant to my needs. Thank you.!
7 years ago
Thank you anandraj. I have solved that problem.
7 years ago
Dear JavaRanch forummers,

I have a problem while trying to deploy my application to the Weblogic server on my laptop. The following is an excerpt of the stack trace.
<28 Ogos 2013 4:29:46 PM SGT> <Warning> <WorkManager> <BEA-002919> <Unable to find a WorkManager with name Sync_Portal_To_All_WorkManager. Dispatch policy Sync_Portal_To_All_WorkManager will map to the default WorkManager for the application iCareEAI_Sync_EAR>

<28 Ogos 2013 4:30:40 PM SGT> <Warning> <HTTP> <BEA-101162> <User defined listener org.springframework.web.context.ContextLoaderListener failed: java.lang.OutOfMemoryError: Java heap space.
java.lang.OutOfMemoryError: Java heap space
at java.util.Arrays.copyOf(Arrays.java:2882)
at java.lang.AbstractStringBuilder.expandCapacity(AbstractStringBuilder.java:100)
at java.lang.AbstractStringBuilder.append(AbstractStringBuilder.java:390)
at java.lang.StringBuffer.append(StringBuffer.java:219)
at org.springframework.beans.factory.BeanCreationException.toString(BeanCreationException.java:154)
Truncated. see log file for complete stacktrace
>



The application is Spring framework based. The RAM installed on my laptop is 3.48GB. The machine is running on XP and is 32 bits. The Java Heap settings are as follows:

MEM_ARGS=-Xms1024m -Xmx1024m

I know that this issue has been raised many times in many forums yet following the advice in those threads got my nowhere. I believe my problem could be unique, hence my decision to post an unique thread. If my request is too vague please do request for more.

Thank you all in advance.

7 years ago
Dear all,

I have been trying out the tutorial found in Tutorial: Installing Tomcat 7 and Using it with Eclipse. I have problem in following the following step outlined in the Section : Copy the ROOT (Default) Web App into Eclipse. The step requires me to the Go to the wtpwebapps folder, R-click, and paste ROOT (say "yes" if asked if you want to merge/replace folders/files). This is need in order for me to see the Tomcat welcome page after I start it up. However when I go to the workspace of Eclipse I do not find such folders.

My eclipse is installed in
C:\Documents and Settings\TM31031\My Documents\HOME\ECLIPSE\eclipse

The version of eclipse : eclipse-jee-indigo-SR2-win32

The installation directory of Tomcat :

C:\apache-tomcat-7.0.27



The explanation of the Tutorial.
Copy the ROOT (Default) Web App into Eclipse.

Eclipse forgets to copy the default apps (ROOT, examples, etc.) when it creates a Tomcat folder inside the Eclipse workspace. Go to C:\apache-tomcat-7.0.8\webapps, R-click on the ROOT folder and copy it. Then go to your Eclipse workspace, go to the .metadata folder, and search for "wtpwebapps". You should find something like your-eclipse-workspace\.metadata\.plugins\org.eclipse.wst.server.core\tmp0\wtpwebapps (or .../tmp1/wtpwebapps if you already had another server registered in Eclipse). Go to the wtpwebapps folder, R-click, and paste ROOT (say "yes" if asked if you want to merge/replace folders/files). Then reload http://localhost/ to see the Tomcat welcome page.


Thank you.

ROBINSON
Hi Sumit,

If I right click, I can see that there is a "Watch" option is that what you mean. I used it previously to right click on a variable and click watch. I thought it was just to watch that particular variable. or is there a another option which is known as "Watch Action". Thank you.
Dear all,

I am trying to debug my codes using the Eclipse that is packaged with Weblogic workshop. For some reasons, whenever I step through the codes I do not see the changes that taking place in the variables. In fact I see nothing on the (x)=Variables view(refer to attachment showing workshop view). Can someone help me configure it so that it will show the variables again. Thank you.


Very truly yours,
ROBINSON
Hello all, I am facing this problem currently,

1. I am trying build a simple programme using the commons-httpclient-3.0.1.jar jar file. I downloaded it and stored it at this location :

2. C:\Documents and Settings\C1272E\My Documents\SPRING STEP-BY-STEP\INSTALLERS FOR DEVELOPMENT\FREQUENTLY USED JARs

3. I have copied the jar from the folder it is in and pasted it in the lib folder.

4. Clicked on all the newly copied jar files in Eclipse and right-click and selected: Build Path -> Add to Build Path

5. This resulted in the jar being placed in the Referenced Libraries folder. This structure can be viewed in the attachment.

The archive: C:/Documents and Settings/C1272E/My Documents/WEB APPLICATION/commons-httpclient-3.0.1.jar which is referenced by the classpath, does not exist.



Can you please advise me. Advance thanks to all.

ROBINSON


.
8 years ago
Dear all,

I am facing a null pointer exception while trying to build a Spring JDBC application.

The code that calls the Dao Interface is :



The code for retrieveNodeLocationCount is defined in the Dao class file of XRefUtilityDao.java as below:

public int retrieveNodeLocationCount(String nodeLocation);



The implementation is defined in this file : XRefUtilityDaoImpl.java as :




For some reason the the execution doesn't reach this portion of code called. Every time I pass the parameters to this method in


It returns a Null Pointer exception.

Is it true that the service poid contains tmm_streamyx?--->false


I am still new at this Spring Jdbc, I was wondering why this problem cropped up. Maybe I missed something. Thank you.
9 years ago