This week's book giveaway is in the Agile forum.
We're giving away four copies of Fixing your Scrum and have Ryan Ripley & Todd Miller on-line!
See this thread for details.
Win a copy of Fixing your Scrum this week in the Agile forum!

Gokhan Cakicioglu

Greenhorn
+ Follow
since Jan 16, 2011
Gokhan likes ...
Hibernate Eclipse IDE Java
Cows and Likes
Cows
Total received
0
In last 30 days
0
Total given
0
Likes
Total received
0
Received in last 30 days
0
Total given
0
Given in last 30 days
0
Forums and Threads
Scavenger Hunt
expand Ranch Hand Scavenger Hunt
expand Greenhorn Scavenger Hunt

Recent posts by Gokhan Cakicioglu

I am just like you too. I google it a lot and in my opinion best way is reading hibernate's manual. It will give you a lot of beginning information. After that you can find `hibernate in action` book. It is quite well too. After you read that documents then you can ask your questions in here. Be good.
Can anybody help me please i am out of ideas. I cant find a way to solve it
This is the console output. First 3 row is about logging i guess and i think it isnt soo important.

SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder".
SLF4J: Defaulting to no-operation (NOP) logger implementation
SLF4J: See http://www.slf4j.org/codes.html#StaticLoggerBinder for further details.
Exception in thread "main" org.hibernate.HibernateException: 'hibernate.dialect' must be set when no Connection available
at org.hibernate.dialect.resolver.DialectFactory.buildDialect(DialectFactory.java:106)
at org.hibernate.cfg.SettingsFactory.buildSettings(SettingsFactory.java:152)
at org.hibernate.cfg.Configuration.buildSettingsInternal(Configuration.java:2833)
at org.hibernate.cfg.Configuration.buildSettings(Configuration.java:2829)
at org.hibernate.cfg.Configuration.buildSessionFactory(Configuration.java:1840)
at student.ShowTime.main(ShowTime.java:16)
I started to learn hibernate for 2 days. Everything was going ok until i got this damned error message whatever i do i couldnt fix it. I google it all 2 days but couldnt understand the solution. Is there anybody in here to help my problem. Here is my configuration file:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE hibernate-configuration PUBLIC
"-//Hibernate/Hibernate Configuration DTD 3.0//EN"
"http://hibernate.sourceforge.net/hibernate-configuration-3.0.dtd">
<hibernate-configuration>
<session-factory>
<property name="hibernate.connection.driver_class">oracle.jdbc.driver.OracleDriver</property>
<property name="hibernate.connection.password">pass</property>
<property name="hibernate.connection.url">jdbc:oracle:thin:@localhost:1521:xe</property>
<property name="hibernate.connection.username">Gokhan</property>
<property name="hibernate.default_schema">GOKHAN</property>
<property name="hibernate.dialect">org.hibernate.dialect.Oracle10gDialect</property>
<mapping resource="student\OgrenciNot.hbm.xml"/>
</session-factory>
</hibernate-configuration>

Help will be tooo mucchly appreciated.

and i am using hibernate3 and eclipse ide and oracle xe as you can understand from the conf file