James Boswell

Bartender
+ Follow
since Nov 09, 2011
James likes ...
Chrome Eclipse IDE Hibernate
Cows and Likes
Cows
Total received
5
In last 30 days
0
Total given
0
Likes
Total received
130
Received in last 30 days
0
Total given
13
Given in last 30 days
0
Forums and Threads
Scavenger Hunt
expand Rancher Scavenger Hunt
expand Ranch Hand Scavenger Hunt
expand Greenhorn Scavenger Hunt

Recent posts by James Boswell

Also, make a class called Inventory with methods like total(), toString() and sort().
3 years ago
Further to Stefan's comments, variables like gameNumber and gameName should be called number and name respectively. They are defined in a class called Game so there is little need for the game prefix.
3 years ago

I would like to create a method that takes two arguments where "BookTitle", "Author", or "Publisher" can be the first argument and "TheLordOfTheRings", "Tolkien", or "DelRey" can be the second argument.


And how would the method know what is being passed? Not the correct approach IMO, separate methods (as suggested by Fred) is the way to go.
3 years ago
That is awful code. The only sensibly named variable is called line which ironically is never used. Like Campbell says, where did you find it?
3 years ago
Your implementation of toString changes every time you post. It is very difficult to help you. Your current implementation means you need to override toString in the Conto class, assuming this is what you actually want.
3 years ago
Manu

Can you please post the entire Client class?
3 years ago

but one thing that students of software engineering have that those (for the most part)who are self taught do not have is the sheer in depth academic understanding of scientific and engineering principals. These skills are essential for being a successful software engineer.


I don't agree with this statement at all. Some of the best programmers I have come across have a background or degree in English/art/photography. It is true that you need a degree to get a decent software role these days but simply having one doesn't make you a good programmer. Possessing traits like determination and perseverance will also help you succeed because without a doubt, there are days when these help you through more than intelligence.
3 years ago

but I have three database table columns that are used for the date when the vehicle was sold, "MonthofSale", "DayOfSale", and "YearOfSale."


Mapping aside, why do you have 3 database table columns to represent a single date? This should be a single column of type DATE.
3 years ago
Adam

The error is nothing to do with loops.

You have declared the variable first in your main method:


The error you are receiving is in the addstock method:


The compiler is telling you it cannot find the variable first as it has not been declared locally. I suspect you want to use the one declared in main but you can't as it is local to that method.
3 years ago
Have you tried

before you get the file?
3 years ago
Adam

Could you please post the exact error message you are receiving?
3 years ago
I assume you mean jar file and not tar?

My first question would be what is the difference between your 3 builds?
3 years ago