Tim Holloway wrote:but avoid mixed cases in c_like_names or underscores in javaLikeNames.
Junilu Lacar wrote: If it's always today's and yesterday's data that are being merged, it might be better to leave that information out of the name and put in the documentation.
Junilu Lacar wrote:
I don't know if the word "data" is really needed. What does the data represent? That would probably be the better word/phrase to use in the name instead of just the generic "data" idea.
Junilu Lacar wrote: For example, add_current_day_total_with_past_day_total might just be calculate_weekly_running_total.
Junilu Lacar wrote: Think at a higher level of abstraction and less at the implementation level when trying to find good names.