Win a copy of React Cookbook: Recipes for Mastering the React Framework this week in the HTML Pages with CSS and JavaScript forum!

Zoltaan Szabo

Greenhorn
+ Follow
since Jul 01, 2013
Cows and Likes
Cows
Total received
0
In last 30 days
0
Total given
0
Likes
Total received
0
Received in last 30 days
0
Total given
0
Given in last 30 days
0
Forums and Threads
Scavenger Hunt
expand Ranch Hand Scavenger Hunt
expand Greenhorn Scavenger Hunt

Recent posts by Zoltaan Szabo

Hi All,

I have an Eclipse-Spring-Maven project. From the IDE i can run it without problems. But when i exported it to a jar file using maven-shade-plugin and tried to run it, i got the following error:

My app-context.xml is:

The Java code that uses this xml is:

Any help would be appreciated.
8 years ago
Thanks. I checked out the plugin from the Apache repository, built it, put it to the Eclipse plugins folder, restarted Eclipse. Then i tried to Run as / Maven build... for my project with single goal. But i got an error:
I think it was a naive way what i have done.
Since then i have downloaded maven-assembly-plugin-2.4.jar, put it to the Eclipse plugins folder, restarted Eclipse, but it did not recognise the single goal.
What is the correct way to use (install?) this plugin?
8 years ago
Hi All,

I wanted to export a project from Eclipse with the Maven plugin with The project has several dependencies, one from my workspace, and several fom e.g. Apache. The export took place, the .jar file was created. I added the main file entry to manifest.mf manually.
When i tried to run the jar, i got an error message:


How can i export a jar fle with the dependencies?
8 years ago
My app-config.xml is as foolows, and causes no more parsing errors:


Now i get a org.apache.cxf.transport.http.HTTPException: HTTP response '401: Unauthorized' error. The http basic auth is configured in the servers web.xml:

In tomcat-users.xml the user is added:


I can open the wsdl in the browser giving username/password.
What can cause this 401: Unauthorized error for the client?
8 years ago
Hi,
now my app-config.xml is:

and the error message is:

8 years ago
Hi All,

My problem has resolved.
There was some problem with our repository. I deleted the reference to this. After that i was able to compile all projects.
8 years ago
Hi,
i have a <distributionManagement> section in the main project pom.xml:
8 years ago
Hi,

All my Maven projects are snapshots. I do knot know why Maven wants to compile them to the release repository. How can i set it?
I also noticed that settings.xml under .m2 folder does not exist. Something really went wrong with Maven.
8 years ago
Hi,

Thanks for your advice. I run Maven/update for all projects. I do not know how to update dependencies? I run clean compile. There was again a failure, with clean istall too.
How do you mean: "Since some of the dependencies are SNAPSHOTs, it doesn't make sense to be doing a release. Do you know why the project is using ext-release-local as the repository? "? Here are several projects in the workpace referencing other ones.
8 years ago
Hi All,

The following problem happened: once i opened Eclipe, all the procects were signed with a red X. Opening the projet tree, there was no error sign in the nodes. Nothig showed me what caused the errors. I could not build the projects. Finally i created a new workspace for Eclipse, checked out the projects from SVN, imported them as Maven projects. (There were two main and several child projects.)
Ther are still two projects showing the red X but not showing what causes the errors. I have tried to refresh, clean in Eclipse. I cannot build the other projects without error either, of course also not the ones with errors. The error message is e.g.:

And for the erroneus project part of the message is:

Could please anyone help me to find a solution?
8 years ago
I tried first to put spring-beans-3.0.xsd and spring-security-3.0.xsd to the same location where my app-context.xml resides. Then according to your reply i created a WEB-INF folder under the root of the project.
I still get an error:

This is not a Web project. I created it from the template Sprig utility project. I am not sure if the WEB-INF folder should be under the root of the project, or under some other folder?
8 years ago
Thank you.
I made the changes but i got an error:


15:24:11,498 WARN eans.factory.xml.XmlBeanDefinitionReader: 47 - Ignored XML validation warning
org.xml.sax.SAXParseException: schema_reference.4: Failed to read schema document 'spring-security-3.0.xsd', because 1) could not find the document; 2) the document could not be read; 3) the root element of the document is not <xsd:schema>.
...
Exception in thread "main" org.springframework.beans.factory.xml.XmlBeanDefinitionStoreException: Line 7 in XML document from class path resource [META-INF/spring/app-context.xml] is invalid; nested exception is org.xml.sax.SAXParseException: cvc-complex-type.2.4.c: The matching wildcard is strict, but no declaration can be found for element 'security:http'.
8 years ago
Hi All,

I am trying to configure a SOAP client to connect and authenticate to a WS. This uses http basic authentication. The client is a Maven-Spring-Axis2 project.
My Java code is:

My app-context.xml causes errors:

The xml editor shows errors for the <http>, <authentication-manager>, <context:component-scan> tags. Obviously, the namespace is incorrect. I copied the <beans> starting element and the above mentioned elements from here:
http://static.springsource.org/spring-security/site/docs/3.1.x/reference/ns-config.html
and i also tried several Google hits from the net. None of them worked. My actual app-context.xml is:

My original app-context.xml was OK, but when i added the security related tags, it caused the same problem. Without them i got of course a 401 - Unauthorized error. Not xml related error.

Could anyone please answer with a valid app-context.xml (whatever it's name is) with http basic authentication?
8 years ago

Ulf Dittmer wrote:HTTP Basic Authentication is not honored by the server?



Yes.
8 years ago
Sorry, there was some misunderstanding. I got the information that we will use http basic authentication. But the SOAP transport went over https. So obiously I had to handle certificates. I added this to the code:


But I got Error 401 Unauthorized message.

This has already been added to the code:



Then HTTP authentication was turned off, and I could reach the ws.
But I still do not know what was wrong with the HTTP authentication.
8 years ago