Let me put some of my thoughts for the method I chose randomly:
1. Looking to method's name first thing which comes to mind is: hm.. "ok, let me have a look again, what does it do/say?".
1.1 promptBoolean, is it wrapper class going to be returned Boolean or primitive boolean? (as subsequent methods indeed return wrapper). I'd avoid Boolean mentioning at all if name cannot suggest clearly what it is going to be returned. In this case it misleads even due to camel case convention. IDE's are clever enough to show return type of method, so to clutter method names with types information makes it harder to read (personally to myself). When methods say getPerson() - in my head I interpret that: "give me person's blueprint/description/entity, but not its class it is implemented in".
1.2 YN postfix. I'd think it is poor choice. Suggests YN but accepts answers true; false; yes; no; as valid. Again, method name suggests upper cases, while hint upon incorrect input suggests lower cases.
And most of the method names are cluttered in my opinion with the information what the method's signature along with return type should and do provide already.